Fresh install: only the root url works


#1

Hi :slight_smile: ,

I just cloned the starterkit repository to start working wiith kirtby with the following command:
git clone --recursive https://github.com/getkirby/starterkit.git

It resides at the root of the /var/www/html folder which is the root of any apache2 server.

Problem is that only the root page works (the assets too :slight_smile:) when I try to access the /about page for example, I get a NOT FOUND error from apache. :frowning:

Is there some specific config to do for kirby and apache to work ? I don’t have this problem on my machine, strange…

Thank you :slight_smile:


#2

Is rewriting enabled on the server?

Did you clone it directly to the server, or did you clone the project to local and then copy to server? If the latter, have you transferred the .htaccess file?


#3

Hi thanks for your quick response

This is a direct clone from kirby official github

in the .htaccess file, I modified the two following lines:
RewriteEngine no -> yes
RewriteBase / (uncommented)

I didn’t touch the others RewriteCond and RewriteRule options. Still not working though :frowning:
Interesting observation, when I go to /panel, it redirects me to /panel/login, but still not found page :laughing: .


#4

Have you checked the tips in the troubleshooting guide? Check if the .htaccess gets loaded and allow overrides on the server if needed.

https://getkirby.com/docs/developer-guide/troubleshooting/installation


#5

Ok thanks very much

The rewrite module was not activated by default on my apache2 config.
I activated it with the following command:

sudo a2enmod rewrite

Now all traffic inside /var/www/html/ is redirected to index.pjp file and Kirby handles the routing from here. :smiley_cat: