Upload Kirby-Project on live server

Hi there,

I’m a Newbie in Coding and Server stuff foremost. Wherefore after finishing my project and uploading it via ftp, I only get a 403 permission forbidden error. Unfortunately, I seem to not find a solution for it – even my coder friend.

First of all, my .htaccess file is uploaded and I tried some changes I saw here in the forum, but it didn’t change anything. Then I thought it’s because my license is still on localhost, but the customer service said that my license isn’t installed on my server yet despite the fact that I uploaded it following the .license instructions as well.
It could be a server issue from strato, but I can’t access the server itself.

I’m very lost and hope you can help me here.

Thanks a lot.

Okay there is an update. I upgraded from a normal webhost to an actual server space with strato. Now, I learned that I should install the panel in the config.php, which I did and now I get this message.

My PHP is 7.3 but I can’t see why I’m unable to access my panel now.

Please enable debugging in your /site/config/config.php file, so that we can see what the error is:

If you are really still on Kirby 2, that would be:

c::set('debug', true);

Hi there,

the debug mode is already on:

<?php
return [
    'debug'  => true
    'url' => 'https://marieschaller.com'
    'panel' =>[
    	'install' => true
  ]
];

What I get now ist a 500 error.

Your config syntax is invalid, the commas are missing after each entry:

<?php
return [
    'debug'  => true,
    'url' => 'https://marieschaller.com',
    'panel' => [
    	'install' => true
  ],
];

But this is Kirby 3 syntax, anyway! Your chosen category says Kirby 2? Kirby 2 options are set with `c::set(‘optionname’, ‘value’): https://k2.getkirby.com/docs/cheatsheet/options/debug, see my debug statement above.

Make sure to remove the panel.install option from the config after you have created your first user!

Seems like this was the problem!
My site and my panel are working now! Thanks a thousand times!!