Panel not working

Hi I have created a website I am trying to use with Kirby, I have started with the plain kit and I am editing these files. I have paid for the licence key and I have no idea where I input this. I have tried going to my URL/panel however I just get a white page. What is going on, have I missed a step somewhere?

So you cannot even access the Panel? Please create a site/config/config.php and set debugging to true: https://getkirby.com/docs/reference/system/options/debug

Then let’s see if you see an error.

@dicedmango I gave you more rights, I can’t see any errors on the page you linked to?

Maybe there’s something wrong with your .htaccess or rewriting in general, probably because you are in a sub-subfolder there. Have you included the .htaccess file when you copied the project to the server?
I get a 404 on the Panel Url in the network tab, and while the screen is blank, there is an empty div in the source code which has nothing to do with the Panel.

See the plainkit: https://github.com/getkirby/plainkit/blob/master/.htaccess. Files that start with a dot are by default not shown in the file system, so you might have missed it. It’s better to set these files to visible in the filesystem. Are you on Windows, Mac, Linux?

I am on mac, i have copied the file on that link, which folder should I save .htaccess?

The .htaccess goes into the root of your Kirby project, i.e. next to the index.php etc.

For the .htaccess to work as it should, rewriting must be enabled on your server. Also check the other requirements: https://getkirby.com/docs/guide/quickstart#requirements

Turns out the .htaccess file was in the ‘site’ folder, I moved it to the root folder. It is still not working, I cannot see any panel page?

As I said, I can’t tell if rewriting is enabled on your server or if it meets the other requirements. Also, it might be that you have other .htaccess files in folders above your Kirby folder that might interfere. But I unfortunately can’t tell what’s going on on your server from here.

The blank page is not even a kirby page, it seems, with this IONOS park.js script.

I have also tried running it locally through XAMPP. I get these errors:

Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
Apache/2.4.41 (Unix) OpenSSL/1.1.1d PHP/7.2.25 mod_perl/2.0.8-dev Perl/v5.16.3

On a side note, to install the Panel on a remote server, you have to enable this in your config, see the documentation. But this is not the reason why it fails.


Hm, again, is rewriting enabled? Is the original htaccess present? Are the other requirements met?

I added the .htaccess and I get this error (XAMPP)

The Panel assets cannot be installed properly. The directory “/Applications/XAMPP/xamppfiles/htdocs/PIK/media/panel” cannot be created

Ah, ok, then we seem to be a step further. It seems that the media folder is not writable by the webserver user. What are the folder/file permissions set to (should be 755/644)?

I am not sure what you mean, can you please explain in more detail?

If you open a terminal window and cd into your kirby project, then type ls -al , what do you get?

It looks like this in one of my folders:

sonja@sonja-XPS-13-7390:~/sites/kitty$ ls -la
insgesamt 60
drwxr-xr-x  8 sonja sonja 4096 Okt  6 19:19 .
drwxr-xr-x 14 sonja sonja 4096 Okt 11 14:44 ..
drwxr-xr-x  3 sonja sonja 4096 Okt  6 19:14 assets
-rw-r--r--  1 sonja sonja  742 Okt  6 19:14 composer.json
drwxr-xr-x  8 sonja sonja 4096 Okt  6 19:14 content
-rw-r--r--  1 sonja sonja  456 Okt  6 19:14 .editorconfig
drwxr-xr-x  8 sonja sonja 4096 Okt  6 19:14 .git
-rw-r--r--  1 sonja sonja  535 Okt  6 19:14 .gitignore
-rw-r--r--  1 sonja sonja 1625 Okt  6 19:14 .htaccess
-rw-r--r--  1 sonja sonja   78 Okt  6 19:14 index.php
drwxr-xr-x 10 sonja sonja 4096 Okt  6 19:14 kirby
drwxr-xr-x  4 sonja sonja 4096 Okt  6 19:19 media
-rw-r--r--  1 sonja sonja 1990 Okt  6 19:14 README.md
drwxr-xr-x 12 sonja sonja 4096 Okt  6 19:19 site

Plus the webserver user needs to have permissions to write in the parent of this folder, so that the media folder, that is not present by default, can be created.

this is what I got:

drwxr-xr-x  17 alex  staff      544 12 Oct 20:03 .
drwxr-xr-x  11 alex  staff      352 12 Oct 20:23 ..
-rw-r--r--@  1 alex  staff    10244 12 Oct 20:07 .DS_Store
-rw-r--r--@  1 alex  staff     1624 12 Oct 20:03 .htaccess
-rwxr-xr-x@  1 alex  staff     2073 15 Sep 01:24 README.md
-rw-r--r--@  1 alex  staff  3067595 12 Oct 11:05 UI.pdf
-rwxr-xr-x@  1 alex  staff      738 15 Sep 01:24 composer.json
drwxr-xr-x@  6 alex  staff      192  8 Oct 12:42 content
drwxrwxrwx   5 alex  staff      160  8 Oct 14:32 fonts
drwxrwxrwx  13 alex  staff      416 12 Oct 11:07 img
-rwxr-xr-x@  1 alex  staff       67 15 Sep 01:24 index.php
drwxr-xr-x@ 18 alex  staff      576 15 Sep 01:24 kirby
drwxrwxrwx   7 alex  staff      224 17 Feb  2020 libs
-rwxrwxrwx@  1 alex  staff      208 12 Oct 14:27 main.js
drwxr-xr-x@  3 alex  staff       96 15 Sep 01:24 media
drwxr-xr-x@ 11 alex  staff      352 12 Oct 19:45 site
-rwxrwxrwx@  1 alex  staff     4589 12 Oct 14:03 style.css

Hi I edited this, now I see something when i go to /panel…

However I think this is still an error right?

The same issue, this time with the sessions folder.

What exactly did you do? The /site/cache, /site/sessions, /site/accounts, and the /content` folder must be writable by the webserver.

I’m sorry that you have such issues. I am on a Mac myself as are many people here and never had any issues with the folder rights, so I am surprised you have these issues on a Mac. Note though that you have to change the rights of the enclosing folder, and pass these down to the children folder.

If your folders are now public, this is not a setting you should have on a remote server, though.

If the settings are not correct, you will most likely run into the same issues with any CMS. Even the database-based CMSes store files in the folder system and need those folders to be writable.

Find out as which user and group your webserver is running, that use chown to set the right permissions to your folders.

Hi, I have managed to get myself to a login screen locally. I needed to make: Accounts, media, session, content all public. - However, this still does not work when I upload it to my other server after deleting and re-uploading everything. This is very difficult because I get just a white screen and I see no errors.