Panel showing blank page

panel

#1

Hi,

so I have the Kirby starter pack and the official kirby .htaccess, the very same website is running well on Godaddy but shows a blank page on OVH client’s server… PHP version is 7.0.32.
You can check my info php here : https://paralleles-editions.com/Kirby/htdocs/w00ce9c8/instatising/info.php
What could be the problem here ?

Thanks !


#2

PHP info says that mb_string is enabled, but could you please check if that is really true.

Other than that, could you check the PHP error logs, please or enable debugging in the config.php, maybe we get an error message.

Rewriting does seem to work in general, i.e. you can access all subpages of the Starterkit?

Another thing you could try is to reupload the Panel folder, just to make sure that everything was uploaded correctly.


#3

I reuploaded the Panel folder, subpages are accessible. Debugging is enabled but nothing shows up in the php console. How can I double check mb_string is enabled ? I can’t find any other way ?

Thank you very much for your help !


#4

Hm, you could use one of the mb_string methods in a template: http://php.net/manual/en/book.mbstring.php

If mb_string is not enabled, that should throw an error.


#5

mb_string is working just fine.


#6

Is the panel already installed, i.e. have you created a user account?


#7

Yes I have created a user account :confused:


#8

Hm, have you already tried to set the URL in your config.php? Could you also test if it works if you run Kirby on a subdomain rather then in a subfolder (i.e. point a subdomain to that subfolder).


#9

I tried with subdomain and subfolder, result is the same. Site is running fine but panel is just blank.


#10

And the suggestion with the URL in the config didn’t work either? I’m running out of ideas…


#11

Sadly even when i set the url the result is the same… http://paralleles-editions.com/Kirby2/panel
I’m really mad because I know I had the same problem when uploading my first Kirby site on my GoDaddy server and I was able to fix it at the time. I just can’t remember what I did but now every Kirby site I upload works just fine out of the box. I probably did something in the cPanel. But on OVH, PHP is up to date, mb string is enabled, everything looks all right so I really have no clue on what is happening…


#12

Hm, have you contacted OVH support? Maybe they can help, I assume it has to do with some server setting.

Are you on a VPS/dedicated server or their shared hosting?


#13

I’m on their shared hosting. I’ll try to contact them I guess. Thanks !


#14

If you can sort it out, would be great if you could report the issue for future reference :slightly_smiling_face:


#15

Definitely, I’ll. Even for myself as it seems my memory is not very reliable. I’ll seriously dive into this in a few days :wink: