Panel showing blank page


so I have the Kirby starter pack and the official kirby .htaccess, the very same website is running well on Godaddy but shows a blank page on OVH client’s server… PHP version is 7.0.32.
You can check my info php here :
What could be the problem here ?

Thanks !

PHP info says that mb_string is enabled, but could you please check if that is really true.

Other than that, could you check the PHP error logs, please or enable debugging in the config.php, maybe we get an error message.

Rewriting does seem to work in general, i.e. you can access all subpages of the Starterkit?

Another thing you could try is to reupload the Panel folder, just to make sure that everything was uploaded correctly.

I reuploaded the Panel folder, subpages are accessible. Debugging is enabled but nothing shows up in the php console. How can I double check mb_string is enabled ? I can’t find any other way ?

Thank you very much for your help !

Hm, you could use one of the mb_string methods in a template:

If mb_string is not enabled, that should throw an error.

mb_string is working just fine.

Is the panel already installed, i.e. have you created a user account?

Yes I have created a user account :confused:

Hm, have you already tried to set the URL in your config.php? Could you also test if it works if you run Kirby on a subdomain rather then in a subfolder (i.e. point a subdomain to that subfolder).

I tried with subdomain and subfolder, result is the same. Site is running fine but panel is just blank.

And the suggestion with the URL in the config didn’t work either? I’m running out of ideas…

Sadly even when i set the url the result is the same…
I’m really mad because I know I had the same problem when uploading my first Kirby site on my GoDaddy server and I was able to fix it at the time. I just can’t remember what I did but now every Kirby site I upload works just fine out of the box. I probably did something in the cPanel. But on OVH, PHP is up to date, mb string is enabled, everything looks all right so I really have no clue on what is happening…

Hm, have you contacted OVH support? Maybe they can help, I assume it has to do with some server setting.

Are you on a VPS/dedicated server or their shared hosting?

I’m on their shared hosting. I’ll try to contact them I guess. Thanks !

If you can sort it out, would be great if you could report the issue for future reference :slightly_smiling_face:

Definitely, I’ll. Even for myself as it seems my memory is not very reliable. I’ll seriously dive into this in a few days :wink:

Same problem here. In contact with OVH Support but they didn’t help so far.
@dyfer fer have you solved the problem ?

@Brindavoine Welcome to the forum! Are you also on Kirby 2? Or 3?

Kirby 3. available here

I’ve followed this recipe :

I’m on a VPS. I’ve already purchased a license.
My php is 7.1.32.
I’ve cloned the repository on the root of my server. I can access to the main page but the panel send me this error message : The panel assets cannot be installed properly. Please check permissions of your media folder.
Here are the permission :

root@-------- [/home/admin/web/] : ll
total 32
drwxr-xr-x 3 www-data www-data 4096 sept. 15 00:02 assets
-rwxr-xr-x 1 www-data www-data 742 sept. 15 00:02 composer.json
drwxr-xr-x 8 www-data www-data 4096 sept. 15 00:02 content
-rwxr-xr-x 1 www-data www-data 78 sept. 15 00:02 index.php
drwxr-xr-x 9 www-data www-data 4096 sept. 15 00:02 kirby
drwxr-xr-x 2 www-data www-data 4096 sept. 15 00:02 media
-rwxr-xr-x 1 www-data www-data 1990 sept. 15 00:02
drwxr-xr-x 11 www-data www-data 4096 sept. 15 00:02 site

my config.php has the block :

return [
‘panel’ =>[
‘install’ => true

What shall I do ?
Thanks in advance

Hm, the folder permissions and ownership look ok.

Does you config.php only have this one return statement? Note that you can only have one, everything after the first return statement will be ignored.

What about the subpages, can you access them? If not, the .htaccess might be ignored and you will have to allow htaccess overwrites in your server configuration.

Not sure the permission are right. I’ve tried to access in ssh with root the config.php : impossible. So I’m connected with a user member of the www-data group. ANd I’m unable to write the config.php file.
And it’s wrong.
By the way, another problem, with my ftp user I can’t upload files.
I’d try to reinstall the depot. And setup correct permissions. What do you think ?


How may I ?