Panel not available after the installation

Hello,

I have installed Kirby. I see “Home”, but I can’t access other sites or the panel.

Error 500 when trying to access Panel
Make sure that the PHP mb_string extension is installed/enabled.

https://getkirby.com/docs/developer-guide/troubleshooting/installation

I have read several topics here, but I don’t understand, what’s to do.

Regards

FUSS

You need to login to your servers control panel and install the missing extension. I do this fairly painlessly via Easy Apache on a Centos VPS running WHM.

The process will differ depending on what kind of hosting you have and wether it’s powered by WHM/cPanel or Plesk or something else. In all cases though it should be possible to do it manually via the command line, although this can be a little scary. If you have shared hosting (which I doubt, that extension should be there already) you probably won’t be able to install it because it will affect all sites on that server and hosts generally lock you out of doing so.

It’s also possible you already have that extension installed but it has been disabled in your servers config files. You will need to edit those to enable it, if that’s the case.

If you give a little more info about what your server is running, we can point you in the right direction, or alternatively you can talk to your web host and they may do it for you.

Hello,

thank you for your answer. I have only an FTP access. I send your questions to the admin of our server.

I have uploaded Kirby and edit .htaccess becauce of it’s installed in a subfolder.

Regards

FUSS

Hello,

the provider says, that mbstring is installed.

Regards

FUSS

If it is installed, that doesn’t mean it is enabled as well. Try to use an mb_{whatever}() function in a template to see if you get an error.

http://php.net/manual/en/book.mbstring.php

If you do, ask the provider why he thinks that you get an error message complaining that it is not installed and what to do about it.

Or use
http://php.net/manual/en/function.phpinfo.php in a separate php-page to look at your configuration.

Good luck!

Or use http://php.net/manual/en/function.phpinfo.php in a separate php-page to look at your configuration.

I have write my first php file. ;-). In the overview stands:

It’s that ok so?

Regards

FUSS

You said in your first post that other pages apart from the start page are. not available either? So it seems that the .htaccess file is not working as expected. Have. you made any changes to that file?

Yes, only Home is available. If I click on “Projects”, “Blog”, “About” “Contact” I get the error massage.

No. I installed Kirby with FTP. Then I wanted to login.

Regards

FUSS

Try to set the RewriteBase in the .htaccess. Either to / or to the folder you installed Kirby in. Test both versions.

For other readers:
https://getkirby.com/docs/developer-guide/troubleshooting/installation


I tested all variants several times but I have every time some troubles and it never works reliably. Then I installed it new. Now the website works. I will try to log-in in the panel now.

Regards

FUSS

1 Like

The next issue for the next days. :frowning:
2018-05-10_00h15_17

That’s an easy one. You are trying to install the Panel on a remote server but that is not allowed by default as a security measure. Set

c::set('panel.install', true);

in your config. Remove that line again after installation or set it to false. https://getkirby.com/docs/installation/panel/#running-the-installer

You are right. :slight_smile: Thank you very much for the support. It’s still difficult for me, to finde the needed informations on the help sites. That’s a world of its own.

And sorry for my english. I’m only a boring boy from the densely populated german province called “Metropolregion Ruhr”. :wink:

Formerly known as Ruhrpott :wink:

2 Likes