Can't access panel


#1

Hi,
I’ve been looking for a solution to my problem, tried many but none has worked so far.

The problem is that I can’t access “Panel” for the installation on any local or web server.

Already changed the config.php settings to enable panel.

Local server
Tried on two Apache servers on my Mac.
On “classic” localhost, I get this error:

The panel assets cannot be installed properly. Please check permissions of your media folder.

On localhost/~username I get this one:

Well, stuff can go wrong sometimes and maybe you mistyped a URL, tapped/clicked on a broken link or your computer just wants to drive you nuts. Anyway … keep calm and take a look at our beautiful homepage instead.

I’ve tried to configure .htaccess as seen on many threads, but nothing changed. Kirby is installed in the main folder.

So I tried to install it on a web server.
I get this error:

This page is currently offline. We are very sorry for the inconvenience and will fix it as soon as possible.

Edit: just solved on the web server, but still looking for a solution for local servers.

What am I doing wrong?

Thank you very much.


#2

Try trashing the media/panel folder, particularly if you have updated Kirby recently.


#3

If you are using PHP’s built-in server locally, you have to start the server with Kirby’s router: https://getkirby.com/docs/guide/installation#requirements


#4

Doesn’t work :frowning: Thank you


#5

Could you please provide more information about your local development environment?

Have you tried both suggestions?


#6

I’ve just noticed i have the same issue myself. I never use the panel online anyway, i push from local but its still annoying. All my permissions seem to be correct and setting the media folder to 755 didnt sort it.

Im hoping what ever works for you works for me :slight_smile: