Kirby 2 panel access 404 error

hi!! i install kirby 2. i am trying to access to the panel and give me a 404 error, i have the defautl htaccess, the mod_rewrite enable, i can access to subpages an in apereance it everything ok but the panel redirect me to the login but the server give me a 404. No errors logs in apache2. I try Apache2 ubuntu LAMP (mbstrig mod on), ddev ( docker env ), and xampp

Have you tried to enable debugging in your config.php?

c::set('debug', true);

What PHP version are you using?

What about file/folder permissions and ownership?

Yes but no result any type, any debug message. My php version is 7.2 and de folders and subs ar chmod 777. is a local developement env., the owner is www-data now, after i tried with my so user

Weird you get the same issue on all three, which suggests a wider problem. I’m guessing your running locally on a linux desktop. I do know it runs fine on a vagrant based setup, i would recommend either Homestead or ScotchBox. You can also try the Linux port of Valet (i use the mac version but cant vouch for how good the port to linux is.)

Try to figure the common element between all three that are giving the error. Perhaps its a problem with the way you are accessing it. Are you using localhost in the browser to reach it or have you mapped it to something like “local.test”. Maybe the issue lies with that.

Have you made sure to change all folders and file to have the correct permissions, including subfolders (755/644).

If subpages work, then we don’t seem to have a problem with rewriting and the .htaccess does its job.

404’s on Panel login are really rare if subpages work and as far as I can see they were usually due to permissions. Hm :thinking:.

Do you just get a 404 or are you actually redirected to Kirby’s error page?

Does the /panel folder exist? Was everything correctly downloaded?

Hi Texnixe, the change of permissions have no effect, and the page it show is the redirected error page.
The panel folder exist to.
About the jimbobrjames’ response i try ddev dev env (easy, dockerized and ready to use), a local virtual host created, and the localhost apache. in every env give me the same 404 error.
Thanks for your help texnixe & jimbobrjames !!

Just to make sure we are on the same page:

  • You are using the latest Kirby version 2.5.12 and you are using a fresh Starterkit, not some third party theme, right?
  • mbstring extension is not only present but also enabled?

I’d try to re-download the Kit again and replace the /panel folder. Maybe something got corrupted.

Another thing you could try is to set your Url in the config.php

c::set('url', 'http://your_local_url');

The version is:

static public $version = ‘2.5.12’;

and if i set
c::set(‘url’, ‘http://your_local_url’);

the main css give me a 404 :confused:.

my mbstring extension:04-11_38_49

This is getting more weird by the minute. But you haven’t literally set it to that value but to your localhost address, haven’t you??

yes, is set to my local url

Hi one more time, i try to begin from the starter kit but i had same problem. 404 error.
No template, no debug messages.
My env is a linux machine, i use ddev development env
have somebody one idea??

Could you please post your complete php info? Maybe we can see something there. Hard to debug a local environment problem from remote.

Also, what do you get in your browser’s network tab?

Have you tried using a different browser?