"This page has no blueprint setup yet"

I’m updating from Kirby 2 -> 3. Did all the steps of the migration
But I can’t get the blueprints to work. Almost all the pages uses the default blueprint, but they all state “This page has no blueprint setup yet”. What am I doing wrong?

title: Default
preset: page

fields:
  title:
    label: Title
    type:  text
  titleshort:
    label: Title for menu
    type:  text
  text:
    label: Text
    type:  textarea
  notes:
    label: Notes
    type:  textarea

Delete the complete title field.

Doesn’t do anything.

While you should definitely remove the title field, have you made sure that the folder structure in the /site/blueprint folder is correct.

site/
  -- blueprints/
      -- pages/
           default.yml
      -- files/

Yes, that’s the folder structure I have.
Also without the title field, no luck.

The site.yml contains:

title: Site
preset: pages
unlisted: true

Ok, but your pages do show up on the Panel’s startpage with this site.yml? And the message only appears when you actually open one of the pages for editing?

The default.yml blueprint is perfectly alright and should work.

All the pages show up on the panel startpage. Once opened the message appears.

What are other possible blockage with transitioning from Kirby 2 to 3? Apart from the things mentioned in the upgrade article.

What about the filename? Is the file called default.yml (instead of default.php, because the php extension is no longer valid in Kirby 3)?

Hm, there might be some other glitches regarding details, but the guide has the main blocking points, I think. Those usually affect more complicated setups, which with only a single template you probably don’t run into.

Yes, I’ve renamed all the blueprints and removed the php in the blueprint.

I will try some random things to find out what is happing :slight_smile:

When I add a new page, I’m not able to select a template either. It just state “page”. So the templates are also not recognised. Does this point to somewhere to you?

If you want to add a new page and you can only select Page, then have a look at site.yml. It probably limits what you can create. Also, the standard default blueprint is called page. I wonder if your blueprint is not readable for some reason. What is your Kirby version? 3.1.3?

We had an issue with BOM in yaml files which is supposed to be fixed now.

After trying all kinds of things, I don’t get it to work. I’ve re-read the upgrade from Kirby 2 cookbook, checked every part.
I’m not sure the blueprints are the source of the problem. But I can’t tell what is…

What do you mean by “the standard default blueprint is called page”. In the Starterkit it’s also called default.yml
What do I look for in the site.yml?

The version is 3.1.3.

I’m a bit lost how to get myself out of this situation, I don’t even know what question to ask to get in the right direction.:pensive:

By any chance, does your K2 site use multi-lang?
I had the same issue, and my blueprints only worked when I set languages up:

  • 'languages' => true, in config
  • languages added in site/languages as explained in the docs here

If multi-lang is not configured, a file named article.en.txt won’t match a blueprint named article.yml, but instead one names article.en.yml.

@Malvese This has already been solved in a PM. The problem were wrongly named blueprints, i.e. default.yml.php instead of default.yml.

In a standard, non-multilanguage installation, text files should never have a language extension.

1 Like