The Directory could not be moved

Just tried it several times, and it does not seems to cause the message.
If it happens again i’ll open an issue on GitHub with more details.

Thank you for your help.

Hey texnixe,

I also have this problem. I think it has something to do with changing the panul url. I changed it back now and still no luck. The changes that i make save fine. I just cant hide/unhide or change the order of the pages.

EDIT: i think i know the source of the problem. If you have a folder/program open that uses the kirby dir, you get this error

@Noedel-Man Is there a way we can reproduce this then?


I too am getting the Error “The directory could not be moved” when trying to Edit a page, but my changes are not being saved and the page cannot be deleted.

I made no changes to any Panel files, but have tried clearing the cache and replacing Kirby and Panel folders with fresh installs. Problem persists uh oh.

Any help would be amazing, thank you.

Can you give us some more details about your environment, is that on local or a remote server?

Have you checked folder permissions?

1 Like

Hello again,

It was happening both on my local and remote servers, folder permissions all in order.

I think I’ve solved it - some project names began with numbers, which then generated into the urls. This seemed to be confusing the ordering system Kirby uses by adding numbers as prefixes, so I removed all leading numbers from the auto generated url’s.

Seems to have done the trick!

I also had this problem and found out that it was because I had one image from a content folder in Photoshop. It prevented the folder from being writable.

I don’t know why it needed the folder to be moved because I was only trying to save the page.

But it if anyone else got this problem, make sure you don’t have content files open in other applications.

As I always have multiple programs opened in same time I imagine it was the same reason for me. Thanks for info, I will check it next time.

Just out of interest: Is that on Windows, Linux or Mac (in your case)?

It’s on Windows. Character limit forces me to write this sentence.

I get persistent The directory could not be moved errors, and I cannot change anything on the website anymore through the browser interface. Running Kirby 2.2.3 on a Mac (El Capitan, PHP 5.6.11). I tried:

  • deleting the contents of the cache folder,
  • restarting the OS,
  • verifying and resetting permissions,
  • duplicating the folder,
  • running Kirby in a different browser,
  • quitting all apps except the browser and the Terminal.

To no avail. Any other trick I could try?

Have you tried to replace the kirby and panel folders with fresh installations?

For me too, it’s on Windows, the webserver XAMPP is runing on my client Win10 64 bit, a virus scanner too.

But the save runs and the new version of the contents file is saved!
The error message is mostly wrong!

@mekkablue I had the same error on several MacOS X Servers. The problem I was having was due to the fact that Apache on OS X Server runs as its own user and group: “_ www” and “_ www”. That means that the default file permissions were not allowing Apache to write (or move) files - only read them.

If this is the problem, in order to fix it, you may have to change the permissions on the files.

1 Like

Thx @luxlogica that was exactly it. Now it works as expected again. For reference, what I did was move it to /Users/Shared/ (because I needed it for other users anyway), and allow Read&Write permissions for the staff group which includes www.


I am suddenly getting “The directory could not be moved” error when removing or changing the visibility of any page on a remote server, where the site has been working before today.

I’ve tried:

  • Replacing Panel and Kirby files with fresh download
  • Clearing cache
  • Checking permissions (public_html 750, folders 755, files 644)
  • Restarting OS
  • Only having browser app open

Not sure where to go from here, any help would be brilliant.

I had this happen to me yesterday (for the first time ever), too.

For some reason, I had two of the same posts visible with following numbers and exactly the same URL-appendix. That did seem to throw Kirby off completely and it also did behave strange in other parts of the panel. You might wanna check that, maybe that happened to you too.

Yes! Thank you!

There were indeed a couple of pages with the same leading numbers, and some duplicates of projects (one visible, one invisible) which must have been confusing everything.

Thanks for your insight :smile:

It also happened to me today: I rebased changes made by users on my own Git repo with older content. A folder had been renamed (something like 6-contact to 5-contact) and for some obscure reason I ended up with both in my local content folder.

Sorry for reviving this topic, but the same error message appears for us on Kirby 2.5.4. Users can’t delete or change the status of any pages, sometimes the error also appears while trying to save changes. I’ve tried:

  • to clear the site/cache folder
  • deleting /kirby and /panel and reuploading them from the newest starterkit
  • deleting certain plugins such as Pagelock
  • checking the permissions of the folders/files (750, 755 and 644)
  • checking for duplicate folders and deleting all of them

Nothing helped. This only seems to happen on the remote server, on a local server deleting and changing the status of pages works fine. Is there anything else I can try to fix this problem, or do I have to completely uninstall Kirby and reinstall it from scratch?