Sftp deployment - fortrabbait


I’ve built a Kirby site and I’m having a hard time with deployment.
My Fortrabbit dashboard tells me my domain is routed correctly, I have uploaded the files (including .htaccess) with SFTP transfer but I’m getting a 403 error. My domain is registed with easyhost.

Do I need to add or edit a file in my site folder with the domain name, etc?

Thank you!

Welcome to the community :slight_smile:

Did you set the permissions on the files and folders properly? Fortrabbit is Kirby freindly, ive used it my self in the past (not for some time though).

I would suggest removing the files and placing just a plain index.html with just a hello world! message in there… if that works, you know your domain etc is ok and you can move on to other options to solve it.

You can explicitly set the URL kirby is using url | Kirby CMS

Howerver, it should be auto detected.

hello, thank you! I tried what you suggested with an index.html file and this works. Can you elaborate on the permissions on the files and folders? I suspect this may be the issue.

I beleive files should be set 644 and and folders should ber set to 755. Your FTP program is probably able to set that on the fly for you when you upload, have a look in the settings. It would be tedious to do it manually.