403 error when uploading complete files via cyberduck, help!

I am assuming I’m doing something fairly simple here – and wrong, but hoping it can be solved easily.

I uploaded the complete files for my kirby site via cyberduck to the ftp, and a 403 error came up on viewing the site.
I read this would be a permissions issue, and changed the uploading settings to change all files to 644, and folders to 755. This didn’t make a difference, so I changed all files an folders to 755. Still no joy.

When I put up a test html file on there, it reads it perfectly. So not sure where it is going wrong. Is there some settings on the CMS I need to do? Is there something awry with the PHP settings? What else could I try to figure out what is going wrong?

Many thanks in advance

Try setting the rewrite base in your .htaccess:

//if the project is in the web root
RewriteBase /

//if the project is in a subfolder
RewriteBase /my_subfolder

Ah yes, I forgot about that.
I changed it, but still no joy…
Do you think its still a permissions thing or something more with the hosting?

Don’t worry! I figured it out. I totally put the details of the kirby licence in wrong.

Panic over.

Thanks v much for your help!