Getting 403 Forbidden Error

I’ve read a few 403 error topics in the forum, but none seemed to be my exact issue.

I am trying to upload my Kirby project with FileZilla in a subdomain on my webpage and always get:

403 Forbidden
You don’t have permission to access this resource.
Apache Server at Port 80

I checked the folder authorizations (which were fine) and changed my .htaccess to RewriteBase /mysubfolder.

Nothing helped. I get the same error when uploading the starter-kit in there.

What am I missing? Thanks.

Welcome to the community!

  1. How did you check the permissions?

  2. Test, if the webserver is able to serve any other file from the webroot, i.e. a static index.html with some content, and a phpinfo.php file with no content except <?php phpinfo(); ?> to see if PHP is working and simultaneously getting information about the web server and PHP.

Thanks Adspectus.
I very much appreciate your help!

  1. I right clicked on the folders/files on my FTP-Server and checked the authorisation numbers.

  2. Static files work fine. When uploading the phpinfo.php I get the same Error.

So I assume this is an issue on the server side?

Sorry, if this is basic and I’m just too stupid… D:
And thanks again for helping.

If you mean the octal values representing the permissions for owner, group and world, that might be not enough unless all files and folders through the whole file system hierachy are world readable. Then the running user of the web server shouldn’t matter. If not world readable, then the user/group who owns the file and the webserver’s user/group come into consideration.

However, if static files are found and served by the webserver, it shouldn’t be related to permissions at all. Hence, the question is why PHP files are not found or executed and thats where your provider/hoster comes into play. Compare the requirements of Kirby with what your provider/hoster offers, if that match at all.

I think it should, but maybe I’m missing something. I’ll get in touch with my hoster then.
Thank you for your help and patience! :slight_smile:

Ok, so my provider fixed the issue.

Apparently the function “mod_rewrite” wasn’t activated yet…

Thanks again and have a great day!