Panel Not Working Correctly after Migration


To preface this post, I would like to note my specialty is in web design, not development. My knowledge base is that of HTML, CSS, and some JS. I’ve only toyed with other languages, and I am not familiar at all with Kirby.

So, I have been having an issue with the cPanel after a recent server migration. We moved to a GoDaddy server and the front of the site works just fine - no issues there. The CMS - Kirby - has not working correctly since. I can sometimes edit items, but often I cannot. If I try to go beyond the dashboard, it bumps me to the login page. Attempting to login only results in the login page refreshing. If I try to select my name, edit, or try to select any of my recent updates, it gives me this error:


Solutions I have tried so far that have not worked:
disabling server firewall
.htaccess “rewrite /” edit
.htaccess “Options -Multiviews” edit
php.ini “tmp file location” edit
setting the URL in the config.php

Hm, that looks similar to this problem: Can’t edit files on server (works fine on local), unresolved or at least we didn’t get any further feedback. Also on a Godaddy server.

Do you get any error messages in the server error logs or in your browser console?


Looks like nothing in the server logs and nothing being reported in the browser log.

So, no go on that front.

Hm, I’m sorry that I can’t provide any further insights. I think, this is likely a server configuration problem.

Are you redirecting correctly from non-www to www or vice versa? Have you tried setting the URL in the config.php?

I don’t believe I have.

I currently see two:


Which of these would I edit?

That looks as if you have two separate Kirby installations. I’d say the first as the second seems to be a test installation.

Try to add:

c::set('url', '');

Does not appear to help.

Forgot to mention, but another issue is that anyone can seem to access /panel. It does not appear they can do anything beyond see the panel (as whoever was logged in last), but, nonetheless, kind of troubling.

So, yes. I agree, it appears to be a server config issue (it was a thought from the start). But the GoDaddy rep I have been talking to is not sure where the mis-configuration could be, assuming that is the case.

What ? Anyone can actually see the dashboard of the last logged-in user? That should not be possible. Do they have any caching enabled on their servers?

Your “What?” was something I said as well when I found that out. Albeit, a bit more NSFW… even though I was at work.

*edit: I also know this is true because I was able to do it on my home desktop. A desktop I had not used for for even visiting our website let alone work.

As for GoDaddy, I want to say they do. I’m not sure if I can adjust that in the GoDaddy panel, though. I’ve been trying to get a hold of the rep for a few hours now, but it seems like he is busy. I’ll see if I can get him to comment on this as well.

Well, Godaddy are rather famous for their support… bad support. Hope you can work this out with them.

Me as well.

I’ll report back on any further happenings on this issue.

I’m sorry that I’m late to the party, but we had a very similar case when GoDaddy had PHP caching enabled on the server, but the support didn’t even know about it. As far as I remember the last client wasn’t able to resolve it properly with GoDaddy as well and had to move. They are a horrible company and I can only recommend to search for an alternative. I’m sorry :confused:

@CameronZ Theres a long thread over here on Kirby friendly hosting companies.

@bastianallgeier No worries. I did just try modding the php.ini file to disable the PHP caching, but no go.

As for moving hosting, well… that’s out of my hands. I recommended going back to what we had, which was indeed a Kirby friendly host (“A Small Orange”), but that is all I can do. Right now, it seems we’ll try and get the original devs in to try and solve this problem, if possible.

Still, I’ll pass this on and report back here on what happens.

Preliminary success!

After working with one of the original devs at the company that made the site for us, we came across an area buried deep within the security settings for… caching (wait, what?)! I currently have our website set as a “developer” URL (e.g. no caching) and it seems to now be working as intended. It’s been only a few days, so I’m still on the lookout for issues, but it’s been clean so far.

Well, at least, light on the horizon :slightly_smiling_face: