Panel completely blank

(and thanks for making Kirby such a great product!)

After pulling from GitHub to a new server the exact same content as local and development, /panel worked (with new user setup) right after I refreshed the site /panel. Now I get a blank page.
I checked many other threads here but couldn’t find any solution.

This is the preview site (To which I haven’t mapped the final domain yet):
[Removed link for privacy]

The exact same content works on development (identical server):
[Removed link for privacy]

All subpages work. No error logs, no debug info. I guess the problem is the address not being xx.yy.zz? I tried already RewriteBase / in .htacces with no luck.

Any suggestions?

Welcome :slight_smile: Have you trying clearing cache / session data from your browser?

Hm, I can get to the Panel login alright!

Me too.

Oh boy. Obviously this works. I spent about an hour trying to fix this myself. Sorry and thanks!

Well, there’s still something fishy… After clearing “cookies and other site data” the panel becomes accessible, as long I don’t refresh when inside the panel: I can close it and open up again, but as soon as I hit refresh I get a blank page whereafter I have to clear cache as well… Huh?

Do you see any errors in your console when this happens? Turn on debugging in your config to get meaningful errors before you check the console.

Oh, I actually do:
GET 404 (Not Found) site:433
which is:

It seems related to Images in panel wrong url

That’s what I thought. What is this preview stuff? Strange that the app.js file works, but not the vendor.js nor the images.

Some hosts (like media temple, which i think this is) give you a temporary URL to access the site on while you are waiting for DNS to update. I think the issues is the Apache server is configured to what the domain will be when the DNS works, and the preview URL is like a proxy so basically Kirby is struggling to understand where it lives.

Looks like it but nevertheless strange that it gets 2 of 3 files right.

Yeah, I think there lies the problem.
It’s actually
I’m pretty sure it will work as soon as I change the domain mapping to this host. However it’s still pointing to another host that’s currently live. It’s not a huge issue, but it would be great to work with this before going definitely live.
Any hints what I could do? Shall I talk to the hoster? What could they change if there is something?

I’ve forwarded the question to our team slack channel, let’s wait and see.

You could set a subdomain up to point to the new hosting and work off that instead.

That’s very strange, I have never seen this issue before. Looks like a provider-specific issue to me.