Kirby class not found

Hi everyone,
I’m kinda new to Kirby. I’ve been trying to launch a website with heroku, have manipulated few things and wasn’t able to. I think I understood having a server issue since I kept getting a “frobidden access”, so I tried to install Apache Server and I think it modified my app root.
Now I am stuck with this error and I can’t even open my localhost anymore. Could someone help me with this ?

Fatal error: Uncaught Error: Class "Kirby" not found in /Users/hannahbroucaret/Desktop/website_starterkit/website-starterkit/www/index.php:5 Stack trace: #0 /Users/hannahbroucaret/Desktop/website_starterkit/website-starterkit/www/kirby/router.php(14): require() #1 {main} thrown in /Users/hannahbroucaret/Desktop/website_starterkit/website-starterkit/www/index.php on line 5
type or paste code here


I’ve got the same error. Do you what it was?

Thank you

Make sure that the kirby directory is fully uploaded. You can do this by deleting and re-uploading the kirby directory.

I get in managed hosting (Allinkl):
Fatal error : Uncaught Error: Class “Kirby” not found in /www/htdocs/foo/htdocs/index.php:5 Stack trace: #0 {main} thrown in /www/htdocs/foo/htdocs/index.php on line 5
after installation for every url i call. First installation went fine a few months ago on a different server … this one started with 500 and it continues with problems … uploaded everything a second time … folder rights? Some hint to debug this? Thanks a lot …

What did you upload to the server, a Starterkit?
How did you upload? Is the /kirby folder fully uploaded?
What are the permission settings and ownership of the uploaded files/folders?
What’s your server and PHP version?

Apache with PHP 8.1
Upload via FTP
Seems to be complete
Folder/file permissions: i will check tomorrow
Certainly a stupid little thing…

I copied my sftp.json from an old project in VSC to this project → “vendor” is excluded → bad → problem solved :wink: