Hosting Kirby on fails

Hey Folks,

I have some problems with hosting Kirby on Every time I ran into problems during final upload I had taken the Kirby Starterkit, fresh from the page. So i’m sure to use the default .htaccess etc… Same right now, I tried to upload the Kirby Starterkit via ftp to the domain space. By the way, the upload runs perfectly.
PHP 5.4 is running on the space; phpinfo() looks also good. If i switch to Kirby Website I only get the “ picture with Internal Server Error 500”; Enabling the kirby Debug function fails - or, the point didn’t gets touched. Tried to run without the htaccess file also fails.

Which other checks i should try?


Not sure the specifics of that might cause something like this, but can you check the apache/PHP logs from within your control panel? 99% of the time, they hold the key to the problem.

Unfortunately no! I get only access to the ftp.log ( god knows why we need this ). Apache / PHP log don’t exists.

Hmm, very strange. Can you check the permissions are set correctly? Your
FTP client should be able to show you those. Check especially the content,
cache, accounts, and thumbnail folders, as those are the ones I’ve seen
break things with incorrect permissions most often.

What you could also try is to set the RewriteBase in the .htaccess.

.htaccess failed; found no way to fix the problem.
I dived into index.php and kirby/kirby.php. The fail starts in the function, named launch:

$this->response = $this->component('response')->make($response);

Will go a little bit deeper this eve.

I think you should choose another hosting provider with a more solid setup, for example Uberspace. Their support is very helpful. :slight_smile:

Yeah, that’s right. The hosting solution isn’t kind of nice.

By the way. thumb creation didn’t work; thats the problem and also the problem why the kirby Starterkit don’t works there. I can remind that there was a problem in the past - but not with Kirby 2.3.2 and php > 5.4.x.