Website Uploading Problem

hey guys,

i’m trying to upload my first Kirby website and i can’t get it to work online. i started by turning on the DesktopUtility App so i can see all the hidden files, then dragged everything into my /public_html directory using FileZilla the way i always do with pure HTML + CSS websites, but nothing!

i have tried uploading it to both Bluehost and GoDaddy servers and neither work, however when uploaded to GoDaddy, this shows up (/northerntech is the directory i created inside another website i made just to test it out):

Parse error: syntax error, unexpected ‘[’ in /home/content/63/12050963/html/northerntech/kirby/vendor/getkirby/toolkit/helpers.php on line 322

with Bluehost it’s just a white page or a general 500 error page. any ideas, no clue what else i can try or what the problem might be…

really appreciate your time!


GoDaddy: must be an old PHP version. Make sure you have at least 5.4, we recommend 7.x

As regards the blank page/error 500:

  • Were all files uploaded correctly?
  • Also check your PHP version.
  • Doublecheck if the .htaccess file was uploaded.
  • Try setting the rewrite base in your .htaccess to /):
    # RewriteBase /mysite
    RewriteBase /
  • Check your server error logs.

Try adding a php info page to the site and see what information it gives you. Match this against Kirbies server requirements and go from there.

Remember to remove it afterwards, as it can be a security risk to leave it there.

thanks guys, both answers helped and i got it to work on both servers now!

incase anyone else has this issue, i will explain what i did:

when it comes to BlueHost, i checked the version of PHP after installing and it told me i was on V5.4.X in the cPanel, but when i used @jimbobrjames advice it told me that i was actually on like V5.2 or something. so i went into the settings and changed it to V7 and it started working immediately.

as for GoDaddy, it was also on an old version, so i went into the settings and updated it to the newest one i could. i also had to edit the .htaccess file to RewriteBase /mysite since it was in a sub directory.

anyways, thanks for the help, feel a bit dumb for posting about such a simple issue (although i find it weird the these hosting companies don’t keep their servers updated to the newest versions) but hopefully it can help someone else down the road.

thank you!

Well, yes, it’s a typical pitfall, always good to check requirements and actual setup first. I wonder why so many hosts are still on these old, outdated PHP versions.

It is annoying. I dont think I have every had a hosting account that defaults to most recent version of PHP. Even my brand new VPS insists on the operating system version of PHP 5 as a default.

@Oli I would strongly suggest, if you can, set the PHP version to version 7.x.

hey guys, everything is working great but there’s still one tiny issue. when i log into my panel it says that i am running Kirby without a valid license, even though i did buy one and then followed all the instructions on the Docs…

any ideas why this is happening?

Maybe a typo? Have you replaced “put your license key here” with your license number in your config file?

c::set('license', 'put your license key here');

So it looks like this:

c::set('license", 'K2-PRO-xxxxx');