Kirby 2 Footnote Plugin Not Scrolling To Footnote

In launching this website from two years ago, the footnotes plugin doesn’t seem to be working anymore. I’m using the footnote plugin found here:

And while it seems to load in the footnote syntax and links just fine. When I try to actively click the footnote to scroll down to the bottom it doesn’t seem to work.

Example here:

[There’s a footnote in the first paragraph]

I thought it might be my javascript messing with it but I removed it and it still doesn’t work. I then tried to test it on an older version that didn’t include plugins I added (Columns and SimpleMDE) to see if that was it and it didn’t work either.

It seems to get stuck on the click and not follow through.

Hm, works for me. Something in your browser’s cache?

What browser are you using? It seems to be an issue on chrome.

Safari. Firefox works as well.

Ok. I downloaded Chrome onto my phone and it seems to work fine on that one as well. Going to ask a friend who uses Chrome to test and see if it’s just a desktop issue.

In Chrome it doesn’t work for me, either.

Hmm alright it must’ve been an update to the browser then?

There is an issue on GitHub that’s more than a year old:

And the plugin has been archived…

But anyway, I assume it is some sort of bug in Chrome, because after all, these are just standard in-page links with no JS involved…