Installing Trial Version

I am trying to test Kirby by installing a trial version and then backup a clients information, they have the full version, and test in my environment, make a full site change and then push back to their server with all new changes.

When I try to install I get all 404s after the home page. I cannot see the panel page.

I worked through this example:

and checked through the forums and followed instructions there and could not get it working

and nothing worked…any and all help appreciated.

is your .htaccess file installed properly and is the RewriteBase set?

Yes, I am trying to set up a test area for a live site. The test area is here:

The live site:

as you can see on mine, the CSS is not loading. I am getting the content up, but none of the design is being grabbed. I am totally unfamiliar with Kirby, although I have used other CMS’ over time. I just turned off the language switch but it did not help.

any direction would be invaluable.


Try using the css helper in your header to include the stylesheets:

<?= css('assets/css/your-stylesheet.css') ?>

This was a great help, i have all the css working, i think i do, some of the text does not look great, but its lining up.

I used another piece of code to get the JS coming up, but the flexslider on the home page is not working. I looked through the code on the site and swapped JS paths out with this call:

<?php echo js('assets/js/site.js') ?>

but its still not working.

I am not seeing a file that could help, any ideas on this ??


The javascript seems to be loading alright, but the complete section tag that is supposed to have the slider data is completely empty. Could you pls. post the code that is supposed to output the slider?

so, I am still learning, and I built off of what you put earlier, that the images are not showing up, which was weird.

So i looked at the content files and there were two homes, one from the client, one set up as the test code i downloaded, so it was confusing the path needed for the images.

Deleted the wrong home folder, everything populated correctly.