Content in Panel (randomly) not saving; user logged out or cannot log out without refreshing

I had the same issues, till I deleted my service worker. Could you please check the existence in the dev tools and clear it?

Hi @macx,

which service worker?

Did you find a solution to this? I’m having a similar problem on a Liquidweb server. Works fine on localhost but on the server the panel seems to be cached somehow. I tried the same site on a different server (Fortrabbit) and there it works. So it seems like it is some kind of server configuration thing but no idea what exactly…

In this case it was a problem with caching on the server.

I also ran into a similar problem with cache control headers in my .htaccess/server config recently.

Have you tried to disable caching in the browser?

Just tried it with the browser cache disabled and it works. I’m not sure I can really recommend this as a solution to a client though. Any idea what could be causing this behaviour?

Same for me … I have to told my clients that they have to disable Browser Cache. Not the perfect solution

I think I may have a solution. I added this to my htaccess and that seems to stop the panel cache issues:

<IfModule mod_expires.c>
ExpiresActive off

Can you try if that works for you too?

1 Like

It would probably make sense to only apply this based on environment, i.e. only for Panel URLs using SetEnvIf, not sure of the exact syntax for this.

This might be solved in the future in Kirby itself by leveraging the fetch cache control API.

I’m running into a similar situation. My client is using GoDaddy (they’ve been customers for a while) and when any changes are made in the panel I can see that the .txt file is immediately updated. However, the panel UI doesn’t update. When fields are updated (even deleted) the content stays on the page

I’ve tried implementing the changes @lauri recommended but I’m not seeing any changes. The content is still not saving, and refreshing always forces us to re login

Have you tested with the 3.2 rc? As far as I know there were supposed to be some changes that should take care of this issue though not sure

How do I do that?

Testing now. I’ll let you know if this resolves the issue