Panel reloads and doesn't let me connect

Hi, I’ve been having problems for a few days with access to the panel for one of the sites I’m developing. I upgraded Kirby from 3.7 to 3.8 (currently 3.8.2) but there is no significant change.
The problem is that the Panel gets stuck with this message (constantly updating the connection):

The section “pages” could not be loaded: Cannot read properties of undefined (reading ‘options’)

While testing, I have found that if I delete all users in /site/accounts I can access the panel without problem (it asks me to create a new user) but this works only during the same session. Then it does the same thing again.
Can anyone help me?

I assume this is happening on a remote server, not locally?

Hi @texnixe, It’s happening on my localhost and in the remote too.

Hi, I have tried everything I can think of but I don’t know how to solve this problem. Does anyone have any ideas. Thank you very much for your help.

Is that only on the start page? could you please post the site.yml blueprint?

Also could you debug on browser console with pretty print (bottom left icon {}) to catch exactly which line is the problem?

It happens when I try to use the Panel, I tried different URLs but always redirect to panel/site with the message above. The site.yml is:

title: Site

  # Contact
    label: Páginas del sitio
    icon: page
        type: pages
        status: published

  globals: tabs/globals


Please let me know if you need something more:

Many thanks

It didn’t help. Do you have a plugin, custom field or custom section?

I have this plugins installed:

  • hashandsalt/kirby3-schema
  • pedroborges/kirby-meta-tags
  • medienbaecker/kirby-autofavicon
  • bvdputte/kirby-bettersearch
  • google/cloud-translate
  • kirby-google-translate

No custom sections, nor fields.

Did you follow the error by disabling these plugins?

Yes, If I disable the plugins the error is still there. The only thing that has worked for me (temporarily) is to remove all users in /site/accounts I can access the panel without problem (it asks me to create a new user) but this works only during the same session. Then it throws the same error again.

Did this problem pop up as a result of making changes to the website? Or something that happened out of the blue? You wrote you updated the site, but it sounds as if you did that as a means to recovering from the error.

I got an error from the start when I tried to access the Panel (I usually make a copy of a previous project). With the copy, everything was fine, but at some point (I can’t figure out why) I could no longer access the Panel. I did the update to see if the error would go away, but no.

First, I’d go back to Kirby 3.7 to rule out any issues with that update and clear the cache and the media folder and the browser cache.

Then test again.

Then remove all plugins (and again also delete the media folder). Then test again.

Tested with no luck. I’ve been removing parts, from plugins to controllers, models, etc. The only thing that changes the behaviour is removing all users in /site/accounts.

Feel free to send me a DL link to your project via PM to check it out.

The problem was caused by code in a model that created a new Kirby instance.

1 Like

Thanks for your help, Sonja!