Cant login to Panel

Hi there!

Im having a HUGE problem logging into my Panel.
I recently moved my Kirby site to a new server, and now, I can’t login.
I see the Panel login-form, and when I type in my login-info, and press “Login” - it just “reloads” the page - no errors, nothing!

When I run it on localhost, it runs without problems!
What’s wrong?

Im not using the newest Kirby version - my client wants to keep it this way.
Please help!

Best regards
Aris Kuckovic

I had the same problems:

Turning off the Varnish Cache was the solution for me.

How did you turn it off?

Contacted my host provider.

Okay, thanks. I will try that :slight_smile:


No luck - still nothinh :frowning:
I don’t know what to do - it’s really annoying…
And It’s not only Chrome, it’s also IE, FF, Safari and Opera :frowning:

Automatic reloads could be the symptom of a client-side error. Could you please open your browser’s developer JS console and check if there’s an error right before the page reloads? If there is, could you please post it here?

Hi lukasbestle,

Nope, nothing.
No errors, nothing…
It’s really weird!

have you tried another browser than Chrome?

Hi JanStieler,

Yes, as mentioned earlier, it’s in all browsers :frowning:

Another idea. Have you set all CHMOD rights?
Some day I had uploaded files to an webserver and lost all writing rules.

Hi JanStieler,

I think so.
First, I tried to 777 EVERYTHING - no luck.
Then i gave it 775 - and still nothing :frowning:

Hi Kucko,

can you open your website and open all links in it?
It could be that you have an wrong RewriteBase in your htaccess file.
Do you use an subfolder on your webspace?

If all from the post before fails, I would:

  • check all at Kirby Docs: Installation & Updates > Troubleshooting.
  • check the file .htaccess in the root of your webserver or in the subdirectory, you use:
    • is it there?
    • are all lines correct? In particular, the line that starts with “RewriteBase” (without any “#” in front!) or that lacks such a line.
    • are you using an apache webserver there? If not, then this is your problem! You have to change the settings of your webserver…
  • delete all files in the directory site/cache
  • if all fails, delete all files in the directory site/accounts and immediately afterwards follow Kirby Docs: Installation & Updates > Installing the panel to build your admin account new. I hope, the hashes may be different depending on the webservers.

Good luck!

1 Like

Hi JanStieler,

I can see all my pages/links - no problem there.
It’s just my panel :frowning: Whenever I type in the info, and press “Login” - it comes back to login page with empty fields :frowning:

Hi HeinerEF,

Thanks, but it still fails :frowning:
I’m so close to give up…

Do an Backup off your Website and start with an new Kirby installation on your webserver.
And than we will see whats happend.

Another idea connected with rights, maybe the owner of the webserver is different from the one that uploaded the data?

Hi Texnixe,

Nope, it’s the same :confused:
I checked that already

Okay! Progress!
Now I got this error:

ss_phkkntlqf79fe5gofkp7h480j3, O_RDWR) failed: Permission denied (13) in Unknown on line 0 Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

Any ideas?

Please go back to an virgin starting point.
Everything other is not really helpfull. You should not lost all your work it is only for see whats happen.
If the new installation will work we will merge this with your old work.
And what kind of webserver do you have?