Cant login to Panel

You may want to check out this thread on Stackoverflow: http://stackoverflow.com/questions/5104065/php-session-handling-errors

Hi JanStieler,

The site is hostet at Amazon on an EC-2 server.
It’s an Apache server…

Hi texnixe,

I can’t find those folders :frowning:

Okay, I finally managed to fix my error.
For future reference - if anyone stumbles upon the same mistake - follow these steps

  1. Turn on debug in your config file
  2. Localize where the error occurs (in my case, it was when I tried to access /panel)
  3. Insert following into the file, where the error occurs: session_save_path(sys_get_temp_dir());
  4. Save and upload

That did the trick for me!
Thank you all for your inputs during my error-finding

Best regards
Aris Kuckovic

Hi Kucko,
and now you can access to panel?

Hi JanStieler,

Yes, now I can access Panel, and it works 100% :slight_smile:

2 posts were split to a new topic: Panel does not work: “Cannot modify header information”

+1

This worked for me too. Thanks kucko!

@Kucko -

I’m having the same issue, but even though debug is set to true, I’m not seeing any errors on the page when I attempt to login. Where are you getting that error from?

Also, if you could tell me where you ended up putting that session_save_path(sys_get_temp_dir()); maybe I need to do the same place.

thanks!

Have you checked the php error log file?

Couldn’t find it, and my hosting support is saying one doesn’t exist because there’s been no php or apache errors. Hmm…

Edit: Now it’s working, and I’m not sure why. Maybe a DNS propagation thing after earlier troubleshooting. If below is ringing any bells for why that would be the case, I’m interested to hear though.

If @Kucko or anyone can give insight into why session_save_path(sys_get_temp_dir()); works, that would be amazing.

Currently I can login at www but not at http://

Echoing session_save_path() gives /tmp, sys_get_temp_dir() gives /tmp.

Seems like there is some webserver subtlety that I’m missing.

Additional info - When I first looked in /tmp, there were some session files in there. I deleted them, but then even after logging in new ones aren’t showing up.

Hi @josh.peterson

session_save_path(sys_get_temp_dir()); returns the path used for temporary files.
For some reason, I could not login, because Kirby could not find the path, so I had to specify it.

Have you done any changes to your server recently?
I remember that I got the error after I updated PHP on my server some months ago.

Cheers.