Panel login not wokring

panel

#1

Hello! All of a sudden I can’t login anymore. Nothing was changed by me and also my host allegedly didn’t change anything. Initially everything worked just fine.

When I’m trying to login nothing happens the page just reloads. If I use false credentials the standard error message (»Invalid username or password«) is shown.
One out of 10 times the login seems to be successful. I can see the panel but the next click leads me to blank page with the following message:

{“direction”:“ltr”,“user”:false,“url”:“http://mywebsiteurl/panel/login”}

When a random successful login happens, than the browser console shows an error:

Refused to execute script from ‘http://mywebsiteurl/panel/plugins/js?v=2.5.10’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled.

Don’t know if this is in any way related and there don’t seem to be any other apparent errors.

I’m using Kirby V 2.5.10 and PHP 7.2.

What I unsuccessfully tried so far:

  • fresh kirby install
  • change the PHP version (tried everything from 5.6 to 7.0 )

If I transfer the whole installation to another server it works, so it seems to be server related … I just can’t figure out how. Any help would be much appreciated :sunny:


#2

Are your mime types properly configured on the server? Try adding the Media Types section from this .htaccess file to the bottom of your own. It starts at line 153 and ends on line 236. Don’t add anything else from that file.

Does another browser work? Google tells me chrome can be fussy. You should still set proper mime types though.


#3

Could you try if the error persists with a custom fingerprint:

s::$fingerprint = function() {
  return 'custom fingerprint';
}

Edit: That code would go into your config.php

What is your hosting provider?


#4

Thanks for the suggestion but Mime Types seem to be defined properly. Adding them to my .htaccess doesn’t change anything.


#5

Thats strange, adding them to the .htaccess should have done it I would have thought. Are you sure you added to the correct .htaccess and cleared your browser cache?


#6

I don’t think this is the problem here, we had a similar error message before in another topic.

One such topic could be solved via the fingerprint. Another one was somehow related to some cache settings on Godaddy.


#7

I just added

s::$fingerprint = function() {
return ‘customfingerprint12345’;
};

to my config.php and that did the job.
Also no more Mime Type related errors are shown.

Thanks a lot! :slight_smile:


#8

Ok, then the test worked. However, you shouldn’t just use the fixed string, but rather something dynamic here, otherwise all users would use the same fingerprint.


#9

Will do! Thanks again.