CLI commands don't work

I’m new to Composer.

I try to install the CLI but can’t get the commands to work. I have installed Composer and tried many things. Any ideas why “kirby is not recongized as an internal or external command”?

Click the image…

It looks like the installation process was successful.

The error you get is because your shell (cmd?) does not know where to find the CLI. You will need to add the path where the CLI has been installed (should be %APPDATA%\Composer\vendor\bin) to your PATH environment variable.

I found out how to add it on Windows. That seems to have solved one problem. Too bad I got a new one. Any ideas? Is it something with Composer, CLI or Wamp?

A folder is created but it’s empty. Curl is enabled in my php.ini.

Well, that means that PHP couldn’t send a TLS request because it couldn’t validate the certificate.

There is a possible solution on StackOverflow, but we can’t support Windows issues. Kirby is only officially compatible with Unix-like systems. :wink:
I hope you understand.

1 Like

At the top of it, it was not so easy after all but it’s solved. Wampserver uses two php.ini files. Took me a while to find that out.

What a mess, but now it installed it without complains. Thank you!
C:\wamp\bin\apache\Apachex.x.x\bin C:\wamp\bin\php\phpx.x.xx