Can not login with Google Chrome

When developing I work locally. Now when I tried to move the project to live I hit some trouble with Kirby 2.1.

I can not login to the panel in Google Chrome. I tried both computer and Smartphone. Internet Explorer worked fine and Firefox did not work at first, but now it does. How strange is that?

How can I debug it? Should I put some sub domain setting in the config file? Does not seems like it.

No messages

Feel free to try to login with any username and password. It does not even give an error, just a page reload, not even if I write the wrong username and password.

I cleared the browser cache just in case, no luck.

(Frontend is white and that is correct)

It’s a private site. The pages are only shown to logged in users.

But locally you have no problems with Google? I tried your link and the first time I got an error message but the next time I didn’t. And then I can sometimes trigger an error message by clicking the button repeatedly.

On localhost it works fine even with Google Chrome and every other browser.

On live it works in IE10 and after a while in Firefox, never for me in Google Chrome.


I tried to add a test folder with a clean Kirby install on

When creating the admin user it doesn’t work in Chrome, but in Firefox it does.

This is weird, I managed to create an account using the above hit-the-button-until-it-works-method and to login in but no idea what might cause this strange behavior? Anything in the server error logs?

I will check it with my host.

I tried to upload the same clean Kirby installation to another domain:

On that domain it works in Google Chrome, like normal.

I once had issues with Chrome and Safari (but not firefox, if I recall correctly) where I couldn’t login to the panel on a server with forced SSL. It doesn’t look like you have that turned on though… and I believe there’s been a fix for that anyway (it was loading http assets in https environment, or rather, NOT loading them, preventing login).

In console on chrome I see this error.

Uncaught TypeError: Cannot read property ‘onUpdated’ of undefined(anonymous function) @ main.js:1

Though that doesn’t appear to be the issue. I’m seeing the same error on a working installation. Hmm.

I recently had a similar issue, but did not test it in browsers other than chrome.

In fact, it was server-side, so I’m not even sure that this is what is happening here, but thought I should post it for others who may come across the same problem.

The site was working fine on a local server and a test server, but once I moved it to my client’s live server, the login stopped working. The error logs showed that there was an error initializing sessions - because the directory designated in php5.ini did not exist. I created a new /tmp/ subfolder in the home directory, and changed the designation in the .ini file to this directory.

I moved to another sub domain on another domain on another host as a workaround. It worked. I just leave it there because it works now. My host did not give any helpful information.

I was in contact with my host again and they run a caching system called Varnish. In some rare cases it can create problems with sessions in Google Chrome.

My solution would be, login with Firefox (or IE) when editing content, turn off Varnish or use another host.