Panel 404 Error on Live Server, Works Fine Locally

Ah yeah — I saw that post but unfortunately changing the file permissions didn’t resolve the issue. Any other ideas?

Have you tried re-uploading the panel to production? Maybe something got corrupted during the upload

Yeah, I even tried uploading a completely unaltered version of the latest version of Kirby (except for adding a single user as per these instructions: https://getkirby.com/docs/installation/panel) but still no luck.

Can you check what your PHP version is?
Also, where on the server are you installing this? Could there be another htaccess somewhere?

Could you also provide a link to the site?

It’s installed in a default public_html folder in the root, which is where I have installed other sites using this host in the past.
I couldn’t find another .htaccess file.
Server was running php version 5.6.24, just changed it to 7.0.9. Site is located at http://www.abodyhasnocenter.com (info at http://www.abodyhasnocenter.com/info.php).

This is strange. I’d say it can’t be the .htaccess, because subpages are working, but nevertheless, could you pls. try to put some nonsense into the .htaccess to make sure it is working?

It almost looks like the panel folder is non-existent or empty!

Sorry, I was in the middle of renaming the panel folder to see if that resolves some unknown namespace conflict. One sec…

Ok, now we have a nice Error 500 on everything :slight_smile:

OK, renamed Panel folder back to normal. Adding gibberish to the .htaccess file threw a 500 error on everything as expected.

Ok, that’s good. And the panel folder is also filled with stuff now. But still all we get is the error page :cry:

:sob: I’m out of ideas

1 Like

Have you ever tried to set the url in your config.php:

c::set('url', 'http://example.com');

This is just trying things out now … as I’m clueless as to what could be causing this.

Ever thought of changing your hosting provider?

Also, have you tried to comment out the RewriteBase?

Tried the config.php and RewriteBase ideas, no luck. I’ll try another host…

Have you checked your error logs, if available? As a last resort, you could try to turn on debugging in your config.php.

Turned on debugging, nothing comes up. Only error log entry displayed the following: [Mon Aug 22 10:18:14 2016] [error] [client 69.160.33.68] SoftException in Application.cpp:631: Directory "/home/abodkncn/public_html/panel" is writeable by group

Damn, turns out it was permissions. I had fixed them locally but something got screwed up. After running this cron command on the server everything was fine. cd /home/{sitedirectory}/public_html ; find -type f | xargs chmod 644 ; find -type d | xargs chmod 755
Only remaining issue probably has something to do with varnish cache, because I can’t login on Chrome but Firefox is fine. Can not login with Google Chrome Still, better than no access.

1 Like

Well, so we were taking a little detour :wink: But at least that’s sorted out now. If you can’t just turn Varnish cash off, you might have to contact your provider.

I contacted them but they just suggested modifying the .htaccess file with Header set Cache-Control "max-age=0, private, no-cache, no-store, must-revalidate" to disable Varnish, which didn’t completely fix it. I did notice that if I use incognito mode on Chrome then I am able to login though, so I’ll just use that workaround for now.
Thanks again for all your help!!!

1 Like