Blank home page, and some subpages

Hello :owl:

I uploaded a working local build of K3 into a folder on a server, public_html/k3, and everything continued to work perfectly when visiting I then moved all the contents of k3 up into public_html and when visiting the home page is blank, all other pages work, except children of just one of the pages…

Moving everything back into k3 and still the same blank home, plus blank children of only one of the pages. Rest load fine.

Tried the suggestions in Broken Subpages here anyway, (.htaccess definitely working as tested with junk text and have a working https redirect) but no luck.

Can anyone shine light from a new direction? Otherwise I’ll go to bed and hopefully it’ll be obvious in the morning!

Are any errors in the php error logs?
What is in your config.php?

config.php is simply:

return [
    'debug' => true,

Looking for any error logs on the server and couldn’t find any. Made sure a location was defined in php.ini but nothing appearing at defined location. Was following things on Stackoverflow, as I’m not familiar with php error logging.

What is in public_html?


Does the Panel work?

Which PHP version are you using?

What you could do is enabling error display on screen in php.ini, including startup errors

Thanks for engaging with this from your perspective :slight_smile:

The Panel is fully functional. The PHP version is 7.2.30.

In the php.ini file this is included:

display_errors = On
error_log = /var/log/php.errors

But I’m not sure where to look, as nothing is is var/log

Hm, it’s a bit strange that it worked in the subfolder first and then stopped working when you tried to put it into the subfolder again, as if something went missing in between those steps.

What I suggest you do:

  1. Delete the Kirby project again
  2. Download a fresh Starterkit and upload it to the public_html folder
  3. Check if it works

Deleted and reuploaded the whole project (except content) and all pages loading now. However the Panel then rejected my login credentials, so I continued in the mode of scrapping everything and starting again, and deleted my account and then enabled Panel install on the server.

As you say, something must have happened when I moved the files…but not clear what!

Thank you very much @pixelijn for your help!