Website doesn`t search in the wrong media folder IDs

I have a problem with the media folder. After I uploaded the site to the production server I got the errors that Images will not be found (Error 404). I see that the media folders where the site is searching have another ids than the one I have on my development server.
How could I solve the problem?


The ID’s will alway be different for the media folder. You should not link directly to image files in the media folder, instead use the file methods to get the correct URL for the image. The media folder is generated using a hash based on the file date etc, and will be different on a production server versus a local one, and is prone to change. It is not safe to link to these files directly.

Don’t upload the media folder to a remote. The media folder will be automatically regenerated with the files from the content folder. Think of it as a disposable cache folder.

@jimbobrjames thnaks, yes I know that I should not link directly to the media.
@texnixe I tried to delete the content of the media folder. but this doesn’t solve teh problem. Something is wrong with the generated hashes. The folders with the hashes doesn’t fit with the called image-path.
It looks like that something is breaking the generating of the files.
The html path looks for media/pages/reporting/first-report/aafe7b3ae7-1603574389/thumb-2-464x.jpg but I see in the mediafolder this media/pages/reporting/first-report/aafe7b3ae7-1603574389/.jobs/thumb-2-464x.jpg.json. But I have no error in the PHP logs or from fastcgi.
And I’m a little bit baffled at the moment.

But then the hashes are correct, only thumbs are not generated for the json jobs.

Which thumb driver are you using in config.php? GD or IM? GD is the default. Make sure that the chosen library is enabled on your server.

Check phpinfo() if in doubt.

I have no special declared. But on the server both, GD and IM are installed.
phpinfo() => gd support enabled.

Mmmh what else could it be?

Images too big? Timeout problems? Plugins?

I have reduced the image size and deleted all plugins.
If there is another timeout I have no idea how I can recognize/debug it.
Every time it only generated the json-files and not the thumbs.
Everything from the requirement page is also fullyfied. The nginx-Server is using PHP 7.3.

Have you seen this? No thumbnails generated on Nginx

thank you for this link!
My admin and I we have used now this ngnix config file:

It is a little bit unpurified to use the 404, like in your link. But it work.
After this we got also problems with the markdown-editor. This is solved by using a symlink for the index.js-file in the media-folder.

Hopefully the config could help also somebody else.