Troubleshooting page could add file permission issues

Hi there,

I am trying Kirby3 StarterKit on localhost and images and subpages where not loading.

In the end it was a file/folder permissions issue.

It always happens to me and this is not listed under the troubleshooting page. I suggest you add a section.

I tried the edit on github button but it is broken.


It would be great if you could add such suggestions as issues in the documentation repo:

I’ll look into the issue with the GitHub links.

1 Like

I just fixed the Github link. Should be live very soon.

1 Like



@plagasul I seem to be having the same problem.
How did you fix it?
Thank you.

What are you using for a local server?

Not sure. Just running php -S localhost:8000 in the terminal…
On a mac.

I dont think permissions come into play with the built in PHP server, but I could be wrong. Is the .htaccess file is in place? thats usually the main reason that sub pages do not work. You may need to show invisible files to see it which i think can be done in finder with cmd + .

Yes, it’s in place.
I haven’t tried fiddling with it yet…
Also, links to subpages are working (which is usually how I figure out there’s a problem with .htacess…)

Well usually permissions are fixed with chown on a server by setting to the group and user to the correct values, but I dont know what they should be for the basic built in php server.

I’ve literally just downloaded the zip, unzipped it and ran PHP…
Also, when I navigate the panel, I can’t see the images either and I get this weird error when clicking an image :


Yes i just tried it myself and i get same thing. I would suggest using something a little more robust like MAMP or Valet. The reason the images are not showing up is becuase they are missing, not just bad links. The media folders are empty. It doesnt seem to be generating thumbs, which i guess could be a permissions thing.

I used this method to set folder permissions to read & write
"This page is not writable"
But now, I’m starting it’s not necessarily a permission problem but something else entirely…
Thanks for the help anyways…

First of all, if you want to use the built-in server, you have to power up the site with Kirby’s router:

php -S localhost:8000 kirby/router.php
1 Like

Ah ha! thats better, that works fine.

1 Like

Oh my, I completely missed that…
Thank you very much :sweat_smile: