Thumb, crop or resize on images not working – locally as well as on the server

Hey there

I read a lot of posts and tried all the things that were proposed. Still not working as expected.
kirby version: 3.7.4
php 8.0.0

My user/editors want to load big images/don’t want to care about the images sizes → so I make thumbs like this:

$bild->thumb(['width' => 1000])->url()

That produces, as expected, this:

  background-image: url('http://localhost:8888/imag-url-1000x.jpg');

But the image is still the same size:

What I tried:

'thumbs' => [
    'driver' => 'im'

Is there something wrong with the Kirby version? Should I update? I don’t want to crash anything.

Related Posts I found and worked through:

(This I didn’t try, because it never works – not locally nor on a server)

Is there another idea how to solve this?

Note that imagick is not the same as imagemagick. So if you use the im driver, you need to check if imagemagick is installed on the server

convert -v

Your server might not be able to handle huge images with its current settings.

Oh, it’s not? In the phpinfo file is nothing written about imagemagick except in that table I made the screenshot of.

How do I check for Imagemagick exactly?
Where do I type this?

convert -v

Your server might not be able to handle huge images with its current settings.

That could be! There are images like 3000x4000 px or 1200x900 px – not absurd huge images… I mean, that should not really be a problem, right?

Either way: I would change it like proposed here:

In the php ini file?

In a terminal


Ok, imageMagick was indeed not installed!
It is working now.

Luckily, it is an institution owned server, so they can simply install it.
But what would I do in case it is regular shared hosting?
Why is GD not working out??

Or is it usually common that shard hostings have imageMagick installed? Just confused that I never run into this issue before.

Have you tried if gd works with smaller images? That would at least provide a pointer.

I tried it with a 26KB image on a local mamp without imagick / imageMagick installed.
I removed the

'thumbs' => [
    'driver' => 'im'

from the config file.

There is no cropping, resizing happening whatsoever. :face_with_monocle:

I don’t have an answer for you. Check that gd is enabled for the currently active PHP version (with MAMP, should usually be enabled)

And make sure that the dimensions of the image you are resizing are larger than your resize/cropping values.