Subpage default as "invisible". Why?

Hi People,

I’m a Coding and Kirby noob, so please bear with me :sunglasses:

I set up a panel blueprint called „projects“, which can have multiple subpages with the blueprint „project“.
My problem is this:
When I add a new „project“, Kirby makes this page invisible per default. After I added a “project” page I have to click on “Edit” in the projects overview (where all subpages are listed) and then manually drag the new page from the “invisible pages” area to the “visible pages” area.

Is there a way to make new pages visible per default?


The visibility of pages is just a flag. You can either use this flag or not.

What that means is, that while a page that is invisible does not get a sorting number, it is still accessible via it’s URL. If you don’t need a number for sorting purposes, for example, because you sort by some other criterium like the date, you might as well call all subpages in your template instead of filtering by visible.

Also, you don’t have to go to the page view to change visibility, you can do that in the sidebar if you are in edit mode of the page.

Lastly, if you want to make your page visible automatically, you can use a hook.