Kirby 2.4.1 is here!

We wrapped up 2.4.1 with a lot of bug fixes and improvements for 2.4. Thanks for all your feedback. It has really helped us tremendously to find undetected issues and add some nice small improvements. We recommend this update to all users. As always you can either download it from our server:, get it from Github: &, or use the CLI to update by running kirby update.

Here’s the official change log entry:


Hi Bastian.

Fixed broken visible/invisible switch

I have upgraded to Kirby 2.4.1 mainly to get this issue sorted.
However, even after the upgrade the “Visible” option is not there.

There is no visible option, to make the page visible, you have to choose a number.

There used to be as far as I remember in previous versions?

Sorry but it is inappropriate to be using such a method. There are over 400 subpages - how would it make sense having to scroll down a list of over 400 entries?

*The website at question is a news portal where categories just keep growing and growing.

Hm, I don’t remember, really, need to check. From which version did you upgrade?

If ordering isn’t important, set the num option on the parent blueprint to zero:

  num: zero

If it’s an article that you want to sort by date, use num: date instead.

With these options you’ll be able to simply toggle between visible/invisible without seeing that long list of numbers.

For more info check out:

1 Like

Thank you for the reply Pedro.

  num: zero

The above would not be a realistic solution as the articles still need to be sorted in the order they are posted rather than alphabetically.

Numbering by date would be more appropriate - however I cannot get this to work.

I have tried both “zero” and “date” and then I’ve added some test articles in a new category.
These, however, are still using the default numbering sorting.

The blueprint:

title: Article - Text
  num: date
  size: 3000000
  title: title
  date: datetime
  imageselect: imageselect
  author: author
  source: source
  tags: tags
  subtitle: subtitle
  intro: description
  text: content

The panel:

*EDIT: You are right Pedro. I’ve misplaced the code. Thank you :slight_smile: (ran out of replies)

This option should be added to the parent blueprint. It looks like you added it to the child page.