Structure field looks broken since 3.7.0

Hi everyone!

Ever since upgrading from 3.6.6, structure fields in the panel I’m working on look weird.

For example: Here is a “menu builder” I use in the panel, where toggle & pages fields are not rendered as they are supposed to be. Only text field seems to be ok, as it doesn’t need special formatting.

Here is the blueprint code for the structure field:

type: structure
    type: toggle
    label: Menüpunkt ist Seite / Text?
      - "Seite"
      - "Text"
    width: 1/4
    type: pages
    label: Menüpunkt (Seite)
    max: 1
      query: false
      textOrPage: false
    width: 1/4
    type: text
    label: Menüpunkt (Text)
      textOrPage: true
    width: 1/4
    type: toggle
    label: Hat Untermenü?
    text: Hat Untermenü?
    width: 1/4
    type: pages
    label: Untermenüpunkte
      hasSubmenu: true
    width: 1/4
      back: white
      query: icon

Interestingly when clicked on a single entry, the entry is rendered as expected:

I’m not sure if this is a general bug or something to do with my blueprint code. But I believe it can be traced back to / related to this PR by @bastianallgeier Improved table previews and usage of table component for plugins by bastianallgeier · Pull Request #4294 · getkirby/kirby · GitHub

I have tried to create a new structure field, with examples from the Kirby Structure Field Reference, yet the same problem persists.

I’d appreciate any help! (Did anyone else have a similar problem with structure fields? Is this a bug? etc.)

Thanks in advance

Hm, have you tested with 3.7.2? Looks like this for me in the latest version:

Hi Sonja, thank you for your answer.
Yes, I have indeed tried it with 3.7.2 & as well.

Hm, wondering why I get a different result with a completely new Starterkit where I added the exact same field you showed above.

Have you deleted the media folder after updating?
Are you using any plugins?

1 Like

oof, this was it!:persevere:
I deleted the Retour plugin by @distantnative (and I now realise installed version was not supported with the latest Kirby versions) and structure field works now as expected.

Thank you @texnixe!

1 Like