Kirby

SSL problem with Kirby CLI [Windows 10]

Hello

i have a Little Problem whit the Kirby CLI on Windows 10, if i type kirby install testseite --kit starterkit
i got this Error Message [GuzzleHttp\Ring\Exception\RingException]
cURL error 60: SSL certificate problem: unable to get local issuer certificate

i already google about the problem, but maybe you Know how to Fix it?

Simon

I spent hours of figuring out how to get it work and failed too.

There is a great guide on how to install curl on windows 7 (http://support.gnip.com/articles/curl-on-win7.html) which I followed along. However I get curl working for the https protocol on windows 10 but the kirby cli still wont work.

1 Like

Tried it with Powershell (Windows + R > powershell) and it worked.

git clone --recursive https://github.com/getkirby/starterkit.git

(of course this is different than your cmd but may be it can help).

whit Powershell i have the same Problem :confused:

Well, I cloned it outside the xampp directory (just a quick test).

Maybe the certificate of your localhost is not valid (because… it’s a localhost :wink: ).

he wants to use the kirby cli not the git clone command :stuck_out_tongue:

http://stackoverflow.com/a/34883260

http://stackoverflow.com/a/24618403

http://stackoverflow.com/a/31830614

I know :slight_smile: Was just wondering if both cmd failed (like they did).

i have try THIS WAY and now i got this Error Message

I’m not an expert, but it looks like it’s a signing-issue with the certificate.

As a workaround, you can try this;

Use curl with -k option which allows curl to make insecure connections.

you mean Just type -k in the Console?

-k is an extra parameter in your command

So just add it to the command you used before, and press <enter>.

The options (switches) are also listed in the 1st screenshot (at the bottom).

##It’s not secure!

( but Kirby can be trusted :stuck_out_tongue: ) - but can help to see what is causing the issue.

So right?

kirby install mysite -k --kit starterkit

Yes, just give it a try - can’t hurt :slight_smile:

###Please, note - don’t use it during production, just as a test so sort thing out!

The same Error Message as Before

@1n3JgKl9pQ6cUMrW Just because curl supports a -k parameter it does not mean that any CLI that depends on cURL internally does too. In Kirby -k defines the kit to use, @thesmithy already uses that param.
Also please, please, please don’t recommend disabling security features to fix an issue. It does not fix the issue.

@thesmithy You shouldn’t put the CA bundle in the C:\Windows directory, that is reserved for Windows internally. Please put it in the XAMPP directory as explained in this post and set the path accordingly in your php.ini.

1 Like

@lukasbestle The Bundle is in C:\xampp\php\extras\ssl\cacert.pem

That sounds good. Then the next step is to change the path in your php.ini as I wrote above.

The path is already set on it

;;;;;;;;;;;;;;;;;;;;
; php.ini Options  ;
;;;;;;;;;;;;;;;;;;;;
; Name for user-defined php.ini (.htaccess) files. Default is ".user.ini"
;user_ini.filename = ".user.ini"

; To disable this feature set this option to empty value
;user_ini.filename =

; TTL for user-defined php.ini files (time-to-live) in seconds. Default is 300 seconds (5 minutes)
;user_ini.cache_ttl = 300

curl.cainfo = "C:\xampp\php\extras\ssl\cacert.pem"

A post was split to a new topic: Command Kirby not found with Kirby CLI [Ubuntu 16.04]