Remote::get says certificate has expired

I’m attempting to do a very basic Remote::get call to another web server I control:

$request = Remote::get('');
if($request->code() !== 200) {

Kirby is giving me the error “SSL certificate problem: certificate has expired”, though I don’t believe this is the case. The certificate on the remote site is just a simple Let’s Encrypt certificate that appears to be current. Any ideas for how to fix or at least override this problem? Am I missing something obvious?

For what it’s worth, I don’t have issues calling a “professional”, third-party remote API such as Eventbrite using this snippet.

Thanks very much.

Can’t reproduce that error. How is that showing? As a whoops error? In your error logs? Where are you testing this? From localhost or a remote server?

I tried the same request in a template (Kirby 3.9), made a get request in Insomnia and a simple curl request on the Command line all without any error messages

curl -v --url

I’m working on a local MAMP development environment, and this shows as a whoops error. I’m on Kirby 3.8.

Haven’t tested it on a production server yet, but even if it works, I’m confused as to why I’m getting this error anywhere. Shouldn’t it be entirely related to the remote server—in which case I should get it everywhere?

Thanks for your help!

Wow—I have to apologize. I thought this dev site in question was running Kirby 3.8, but in fact it was still on 3.5. After upgrading, I no longer get the certificate error.

I’m sorry for the miscommunication. However, if you have any info on why I received this error, I’d still be quite curious to hear the explanation.

Thanks again for the help.

Have you tested if the curl command I posted above gives you the same error?

Yes, checking with curl gives me the same “certificate expired” error that Kirby 3.5’s whoops was giving me. Kirby 3.9 doesn’t throw any errors. Any thoughts on why this is the case?

I think it has to do with the cacert.pem that ships with Kirby as a fallback for when the certificate authorities file on your machine is not up-to-date. Something like that, so its not really a question of the certificate on the machine you are querying being out of date, but something in the chain of trust.

Thanks for the info. Everything is working in Kirby, so that’s all that matters. I really appreciate the help.