Problem with migration to SSL

Having migrated my site to SSL Inow have the following errors:
Fatal error: require(): Failed opening required '///kirby/bootstrap.php’ (include_path=’.:/usr/lib/php7.2’) in// index.php on line 6
If I write the subfolder in manually I get to the right page, but trying to reach the panel then produces the same error.
Thankful for all help !

There’s probably a problem with your SSL configuration.

What is in your .htaccess?

Unfortunately I have no influence on the SSL configuration, which is provided(sic!) by the Provider. .htaccess points to the correct subfolder but doesn’t seem to be taken into account.

Have you set the RewriteBase in your .htaccess? If that’s 1+1, then I think you have to set it to /.

Have now tried RewriteBase /. No difference in eror

The provider is United Domains, I shall try it with RewriteBase /.

This is the latest error message after having reinstalled the starterkit. First page appears, but no possibility to navigate

Cannot access protected property Kirby\Cms\App::$urls Sorry was too quick. Appears when trying to call /panel

I have now started from scratch again. Website works perfectly, but panel cannot be reached, just loads index.php again. Where do I start tuning? www.musiktherapie-pfullendorf.de

You seem to have a redirect to the homepage somewhere, either in your .htaccess or in your server configuration or in a route. Unfortunately, I can’t check if normal subpages work because there are none…

Thankyou. Taking out RewriteBase / results in an INTERNAL SERVER ERROR when calling the panel.
other redirects are not known to me.

Could you please post your entire .htaccess file and your config.php file? Maybe we can find something there. This is impossible to debug without any information and is likely a problem with your server configuration. Maybe you can get support from the person who developed the site for you or from your hosting provider.

Sorry for the delay, it’s weekend!
Here they are:

/*

---------------------------------------
License Setup
---------------------------------------

Please add your license key, which you've received
via email after purchasing Kirby on http://getkirby.com/buy

It is not permitted to run a public website without a
valid license key. Please read the End User License Agreement
for more information: http://getkirby.com/license

*/
c::set('panel.install', true);
c::set('license', ' ');

/*

---------------------------------------
Kirby Configuration
---------------------------------------

By default you don't have to configure anything to
make Kirby work. For more fine-grained configuration
of the system, please check out http://getkirby.com/docs/advanced/options

*/

# Kirby .htaccess

# rewrite rules
<IfModule mod_rewrite.c>

# enable awesome urls. i.e.:
# http://yourdomain.com/about-us/team
RewriteEngine on

# make sure to set the RewriteBase correctly
# if you are running the site in a subfolder.
# Otherwise links or the entire site will break.
#
# If your homepage is http://yourdomain.com/mysite
# Set the RewriteBase to:
#
# RewriteBase /Musiktherapie

# In some enviroments it's necessary to
# set the RewriteBase to:
#
# RewriteBase /

# block files and folders beginning with a dot, such as .git
# except for the .well-known folder, which is used for Let's Encrypt and security.txt
RewriteRule (^|/)\.(?!well-known\/) index.php [L]

# block text files in the content folder from being accessed directly
RewriteRule ^content/(.*)\.(txt|md|mdown)$ index.php [L]

# block all files in the site folder from being accessed directly
# except for requests to plugin assets files
RewriteRule ^site/(.*) index.php [L]

# Enable authentication header
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

# block direct access to kirby and the panel sources
RewriteRule ^kirby/(.*) index.php [L]

# make site links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [L]

</IfModule>

# compress text file responses
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/json
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
</IfModule>

I removed the license key, just in case

The config syntax is outdated, but that doesn’t cause your issues. You can remove all that is in there, because you have to register your license via the Panel and the panel.install option should be removed, anyway.

The .htaccess hasn’t been touched, it seems, and since changing the RewriteBase results in an error, it is picked up by the server.

Didn’t you say removing the RewriteBase resulted in an Internal Server Error? But the RewriteBase is not set in your .htaccess.

I’m afraid I can’t help you anymore with this.

On a side note, the website is missing a privacy page that is required under GDPR.

Thank you for all your help.
The Internal server error appears when the .htaccess is untouched, if RewriteBase is set to / then I just get a reloaded start page. I think I need to contact the developer to see if this can be fixed. Once I reach the panel again then I shall think about a privacy page. It’s on the list.

After playing around with .htacess a while, I then decided to set RewtiteBase to /panel, and see there!
it works, the page itself and also panel availability. I’m not sure if this is good coding prtactice, but I am now completely happy. Many thanks to @texnixe for the help and support. Setting this question now as solved!