Function Require Blues for a Newbie

I’m having this issue: Warning: require(DIR/kirby/bootstrap.php) [function.require]: failed to open stream: No such file or directory. I’ve done some research and worked on this for about 2 days and still no answer.
I know my web host is running php 5.4. It works on for one hosting but not the other. I’ve also tried to redirect in the .htacess file with no resolution.

Can anyone share some insight?


Two possibilities I see here:

  • Are the Kirby/Toolkit/Panel folders empty?
  • Nevertheless the wrong PHP version, have you double-checked with phpinfo?

No they are not empty

Double checked with phpinfo? meaning adding this code to the Kirby index.php file:

<?php // Show all information, defaults to INFO_ALL phpinfo(); // Show just the module information. // phpinfo(8) yields identical results. phpinfo(INFO_MODULES); ?>

Thanks for your time.

Put an info.php file into the kirby root folder:


and then call that file directly in your browser.

ok got it:
Looks like no matter how I change the php info its still running 5.2.7.
Does anything stand out to you?

You have to ask your hosting provider to update the PHP version for you. It’s actually a super old version so they should be able to move you to something more recent.

Thanks,@bastianallgeier, I worked extensively over the last two days with the hosting provider and I thought I changed the php version myself. I’ve also asked them to change it. Looks like I’ll have to be more of a hard ass with hostgator or switch providers.

Have you checked this already: It was just a quick google search, but maybe it helps you.

Thanks again.

Yes, that’s the panel I worked with late last night and thought I changed it. I talked to them this morning and they stated something about fixing permissions at the root level and connected me with a senior advisor. We’ll see where this takes me.