Error message on very first setup

I have downloaded Kirby and a suitable skin for it (Frisk), modified some pages to see what is possible, and everything seems to work fine on my computer running Ubuntu 16.10 with the php -S localhost:8080 server. It has taken me some time to get it to run but finally it worked alright.

So now I have done as it said in the documents, just upload all the files to your server and you’re done with it. I’m really glad that it’s so simple as that.

Unfortunately I get the following error message:

Warning: require(DIR/kirby/bootstrap.php) [function.require]: failed to open stream: No such file or directory in /kunden/278730_42327/allprax/index.php on line 6

Fatal error: require() [function.require]: Failed opening required ‘DIR/kirby/bootstrap.php’ (include_path=’.:/usr/local/lib/php’) in /kunden/278730_42327/allprax/index.php on line 6

Must I do something to make the pages I set up appear correctly?

The pages are on

Ulf Bro

Which PHP version is running on your remote server?

Edit: As I just found out, you are using an outdated PHP version, i.e. 5.2. Kirby requires at least 5.4, but we recommend you use the latest version available to you, ideally 7.0/7.1 or at least 5.6.

You should also remove the info.php in your webroot, this information should not be visible to anyone :wink:

I should remove it of course, but it sure did help me in this case.

Thank you ever so much. I found a page in the Customer Menu where I could set PHP version to 7. I did that now, and that solved the problem instantly.

Now I can’t access the Panel. Can you help me to do that?

(What I’ll do next is to put an index.html there which says “we’re working on it…”

I can then still access the new pages, specifically calling up index.php, something which nobody else would ever think of doing.

When the pages are all done I just remove the index.html again.)


You have to enable mod_rewrite (if your hosting allows that), subpages don’t work either.


Google tells me this has to be done with an .htaccess file.

I see there is one. I have tried to edit it. After that my homepage didn’t show up at all. Now I have put the old version back again.

How can I enable mod_rewrite?


I’ve solved it, it works. I found the documentation at “Domainfactory”. It’s done now. Thank you for your help!!!


Ok, so I can delete everything I was about to write :slight_smile:

If you don’t want your half-ready site to leak, think about using authentication to lock your content for unauthenticated users:

Thanks for this advice. And for everything.