Plugin language missing (lt)

This Topic is related to this Issue.
My plugin is translated to german and english in my plugin like this:

    'translations' => [
        'en' => require __DIR__ . '/lib/languages/en.php',
        'lt' => require __DIR__ . '/lib/languages/lt.php',
        'de' => require __DIR__ . '/lib/languages/de.php'

But the customer set the panel language to Lithuanian (lt) and the translation there is missing. :man_shrugging:

I can’t reproduce this.

Installed your plugin, duplicated de.php => lt.php (inside your plugin), selected Lithuanian as user language and all fine.

Tested with 3.3.3-beta plugin version and Kirby 3.8.3-

Did you test this yourself?

I have 3.9.0-rc.1, but as I remember, probably had same or similar as 3.8.3. before and had same problem, will try to check with this version again.

Changed to 3.8.3, it didn’t help. @texnixe do you have Lithuanian as only and default language? @Microman did you test the same way?

O, ok, I didn’t test with languages enabled. Will try later. But that shouldn’t actually make a difference, because here only the selected user language is relevant, not your content language.

Just tested and enabling languages and setting only language to LT doesn’t make a difference.

I could reproduce it with 3.8.1. I changed the language of the current user. My frontend is multilanguage.
I my case non of the other language except de & en is translating.

Maybe it’s important to mention, that i use dynamic blueprint, which is failing.

Interesting, with later versions in my case I added Spanish, and it works. Maybe it has something to do with what initial languages are, as adding other additional language works for me, and in your case you have initial languages EN and DE set in plugin. I don’t know if it helps :slight_smile: Anyway, I think we should move this to github again. I also sent you copy as you asked.

I thing this one goes into the same direction.