PHP Startup: Unable to load dynamic library on shared webspace


#1

I’m getting following error, when i try to open the panel on my shared webspace:

PHP Startup: Unable to load dynamic library '/usr/share/extensions/no-debug-non-zts-20151012/pdf.so' - /usr/share/extensions/no-debug-non-zts-20151012/pdf.so: cannot open shared object file: No such file or directory

On my localhost, the panel works fine without any errors.

In other posts to this topic, you said it isn’t a problem of Kirby, but I’m not that sure, because running an older version (v2.3.2) this PHP error doesn’t exist:

This error came up from v2.4.x or later.

No-PHP-Error (v2.3.2 or earlier):
https://matthiasschulz.com/showroom/kirby/v2.3.2/panel

PHP-Error pops up (v2.4.x or later):
https://matthiasschulz.com/showroom/kirby/v2.4.1/panel/login

I don’t want to use an older version of Kirby to get rid of this problem. Do you have any other ideas? Because of the shared webspace, I don’t have access to the php configuration to make any changes there.

Best regards

Matthias

PS: www.matthiasschulz.com (made in 2016) is using Kirby as well, but with an older version.


#2

It looks like a missing PHP extension. You don’t mention which version of PHP or Kirby you would like to use. I would think the only way to resolve this is to talk to your host, or update Kirby to 2.5.12 and use at least php 7.0 to see if it contains that extension.


#3

Can you log in despite the warning?
Is debugging on or off in your config?

On your remote host, debugging should be off and your errors should be logged to a log file.

If you have access to your php.ini file, I’d search for the extension in that file and either change the path or comment that line out.

The reason why older versions react differently is probably that version 2.4.0 added Whoops error handling… In any case I’d say this is a problem with the server configuration, not with Kirby.


#4

My webspace uses PHP v7.0.1. I like to use the latest version of Kirby, but it throws the same error.
Maybe as @texnixe said, it could be connected with Whoops error handling, that this error just get visible.

I’ll will contact my provider. Maybe he can fix that bug, because this file is listed in the phpinfo under

extension_dir	/usr/share/extensions/no-debug-non-zts-20151012	/usr/share/extensions/no-debug-non-zts-20151012

Thank you for your help


#5

Usually you can define in your php.ini settings what sort of errors are displayed at all (with or without PHP Startup Errors, for example) and what errors are logged. On a remote host, all errors should be logged, but none should be printed to screen.

Hope your provider can help sort this out!