Panel works locally, not on remote server

Remote error:

touch(): Utime failed: Permission denied
Try again or contact your administrator.

Searched through the forum, and set site/accounts/.login permissions to 660

Still no luck.

Maybe you have to change the ownership of the file the panel needs to access as well and change it to the group-user.

Thanks! Not quite sure which file you mean? What would that be?

The .login file to start with, but if it then works and you have issues with updating pages in the panel, the content folder/files in it as well.

Don’t know if that is the issue, but I can’t think of anything else.

Okay, I see what you mean. I adjusted the permissions for the .login file to 660, can’t get the main login screen. Just get that error message.

Yes, but I don’t mean permissions (chmod), but ownership (chown).

Ah, yes, missed that. Okay, will give it a try, thanks!

@elmnt Did you get it to work?

Thanks for the follow-up. I’ve been messing with it again this morning. Still no luck. Here are the current file permissions for the .logins file:

-rwxrwx— 1 greg staff 2 Dec 7 11:12 site/accounts/.logins

I did attempt to change ownership, as well, with no luck.

sudo chown greg:staff path-to-.logins-file

@texnixe Got it working now, thanks Sonja!!

May I ask how you got it to work in the end?

Honestly, I think the repo just hadn’t deployed yet, after I pushed that update. I came back to it, and it looks like those last changes were the trick. Should have clarified that. Thanks again!

Well, at least it works now :slight_smile:, so I’ll mark this as solved.

1 Like