Cannot login to panel "The authentication token could not be stored"

panel

#1

Hello everyone,

I am getting error messages when trying to login into the panel.
I coded the website on my computer using MAMP to display it. From there, I can access the panel. No problems so far. Now I transferred the site to the web and suddenly I cannot access the panel anymore. The error message I am getting is “The authentication token could not be stored”.

I found this thread here: The authentication token could not be stored
But unfortunately it did not solve my problem (and I only understand half what the anser/suggestion there is). I deleted the sites/accounts .php file on the server, and then reloaded the /panel page but then I am getting a multitude of error messages:

  1. /site/accounts is not writable
  2. The thumbs folder must be writable.
  3. The content folder and all contained files and folders must be writable.
  4. /assets/avatars is not writable

I am not proficient enough to understand what is going on and why the transfer from local to internet did not work. Can anyone help me? What more information would you need from me?

Thanks a lot in advance,
F


#2

Wow, as soon as I posted it I found a solution with google’s help.
Problem were the file permissions.
As soon as I changed everything to 777 it worked ( I went to the folders indicated in the error message in my FTP program and hit cmd+i and there I could change the number code from 644 to 777)!
Just posting this here in case someone is as unexperienced as I am and is looking for a solution.

PS: Is it recommended to change it to 777 though? I read you should not do it “unless absolutely necessary”. Is that a case like this or did I make my panel now very insecure?

Thanks!
–F


#3

No, this is not recommended, the permissions should be set to 755 (for folders)/644 (for files).

The solution suggested in the other thread is really what you should be looking for, i.e. the owner of the files show be the same as the one the web server is running under, not your account. Do you have ssh access to your server?


#4

Umm, I am not really sure. My provider is all-inkl and it doesn’t look like there is a specific way of getting access via SSH.
There’s a module in my account profile where I can change the directory owner, and it it already set to the credentials I logged into the FTP with.
I uploaded my backed up website now again to undo my changes with setting all folders to 777 and I checked: folders are 755 and the files within are 644, it’s still not working.


#5

The user and group should be set to www-data. Looks as if you can do this like described here: https://all-inkl.com/wichtig/anleitungen/programme/ftp/all-inkl.com-webftp/besitzrechte-aendern-chown_380.html


#6

Amazing, this solved my problem! Thank you so much for taking the time and helping me!