Panel login fail on new production server

When I move a localy yworking 2.5.12 site to the production server, I can’t log into the panel anymore. When I enter name/password, I just get redirected to the login screen. No error message or anything.
Same thing happens, when I delete accounts and try panel/install - I enter user data and get redirected to the same screen.

Any idea, how this could happen on one server, but same site on local and other remote server are ok?

very often, my login / sessions fail, when not using SSL.

or when jumping between http and https

neither use case has SSL. could there be a case where a certain server configuration could cause this issue?

Hm, have you tried to clear your browser cache? Also, make sure there is no .logins file on the server in the /site/accounts folder.

no cache.
deleting .logins doesn’t help.
already tried deleting the accounts folder and create new account via install, but that creat-user form shows same pattern: enter data, redirect to form with no error message

And you file and folder permissions are OK as well, as well as ownership of the files and folders?

Anything in your php error logs?

Re permissions: I just turned on caching to see if any files are generated, and they are. so I guess permissions are fine?

nothing in the error logs. also debug says nothing.

What about www vs non-www does it work with one of them?

non does. i did have the redirect to www in the htaccess, but already took it out.

i have no access to the server config or any logs (i know, right), but right now the server person is having a look. but i suspect so far they don’t have a clue either.

you could also do a test on another server to see if the issue is solely related to the server??

OK, solved.

The hoster has some kind of strict cookie policy. They dialed it back a bit, now it’s working.
Will post details when I have them.

Thanks so much though y’all for caring! Really helped me to stay calm!

1 Like