Panel keeps rerouting (Invalid panel URL)

Since a few days without any changes made in between the /panel doesn’t work anymore. When reaching the panel it shows the UI + the error Invalid Panel URL and routes to

Locally it works without any problems. I’ve setup a staging environment for debugging this issue. I’ve tried the following stuff:

  • Update /site and /panel folders (After this the UI was shown)
  • RewriteBase /
  • Update .htaccess with newest version

I think the problem is similair to this topic but al the suggested solutions didn’t work. Also a solution was never found.

Hope this very specific case can be solved. I am a bit in the dark here :slight_smile:

What happens if you put the starter kit up on that server? Does that work? Im trying to rule out Kirby itself and rather an issue with your hosting or your specific sites code.

I see errors regarding too many http redirects in the console…

If you really haven’t made any changes whatsoever, I would suspect that something has changed on your server.

It might be a problem with http/https rerouting going wrong

If you are 100% sure that no changes whatsoever to the Kirby installation have been made, contact your hoster to find out if they have made any changes.

@jimbobrjames It works perfectly. So It’s not hosting specific I guess.

@texnixe I haven’t made changes on the code side, the client posted some new content but I am not sure if that influences the panel.

When I found out the problem I updated the /panel with the latest version. Could it be conflicting with an outdated /site folder?

What plugins have you installed?

Did you only update the Panel with the latest version? You always have to update Kirby and the Panel- The version numbers of Kirby, Panel and Toolkit must be identical.

@texnixe I updated the /kirby folder as well. The following plugins:

  • autopublish
  • cachebuster
  • feed
  • kirbygram
  • kirbytextraw
  • oembed
  • relatedpages
  • relative-date
  • robots
  • sitemap

I am right now disabling each of them but still no succes

Do you have a chance to test the Starterkit on the main domain with all the https settings?

There’s some weird redirecting taking place and I don’t really think this is in any way Kirby related. I mean, how can it if you haven’t changed anything at all?

@texnixe Unfortunally I can’t test it there. It could be that with a last update I didn’t check the panel functionallity. I’ll just go back in time on GIT to check where it went wrong. Thanks for now :slight_smile:

@danoszz I noticed that the website allows directory listings. You can and should prevent this, for example by adding this line in your .htaccess:

Options -Indexes
1 Like

Any solutions about this?
Thank you!

Do you have a similar problem? Looks like the TO’s problem has been solved because the Panel is now reachable.

@danoszz linked my topic in the first post. It never had a solution so I moved all the site in my root folder messing up my clean server as it’s not well organized now.

Tonight I will try to put everything in a subfolder and I will see if I still getting the panel error…
Thank you!