Panel Blocked attempt to use history.pushState() Error

Hey everybody!

Today I tried to update my Website to Kirby 3.6
Everything works fine so far but I get a strange Error when I try to access the panel.
In my Console it says „Blocked attempt to use history.pushState() to change session history“ and then something with User and Password must mach.
The result is that the panel login page is just a white background and I can’t login.

I changed back to the version before and it works flawless again.

Any Idea how to fix this?
Does this maybe have something to do with the Kirby Catch files or file permissions?

Thank you!

Have you deleted the session folder, media folder, cache folder, cleared browser cache etc?

Thank you for your reply!

I deleted everything except the cache and session folder.
I’ll give it a try and tell you later if it worked.

Sadly it’s still not working.
Attached an Screenshot of the Error Message.

Thank you!

Where does this other URL with port 9258 come from?

Hey @texnixe

I really don’t know.
But I know that the URL with port :9258 is according to the phpinfo() log, the Server Host. So I think somehow Kirby is confused between the actual url and the host-ip-address.
Never got this Error Messege before the update to 3.6 so I think maybe it’s really a cache/session error. All cache/session files I have to delete are in the site/ folder right? Is there anything else I could have got forgotten?

Thank you!

Little Update on this one:
It’s still not working and I have no idea what to try next.

Since I first uploaded the page to my clients server, I had to change in the config file the server-url via „‘url’ => …“ to make it work.
Maybe this messes with the real URL and the Server-Address?

When I delete the url line (with „‘url’ => …“) in the config file I break the page but get another Error-Log.

Maybe some can give me a hint.

Which plugins are you using?

Hey texnixe,

thanks for your reply.
I’m using no plugins at all.

Could it be a permission issue?
Because I had some issues with this before.

I have no idea what the issue might be, obviously it has something to do with https vs. http, but apart from that, hm. When I google the error I mainly get iOS related results. Can’t remember ever seen this error message before.

Where are you hosting?

My client is an educational institution and has it’s own server. The kirby website is hosted under a subdomain of the main website.
It’s running on apache and php 7.4.
Strange thing is, I had not any issue with the version before 3.6.
Maybe it has something to do with a .htaccess redirection I set up for the »www« and without »www« domain. Or it has something to do with the way I updated Kirby.

Plan is now to reach the server team. Maybe they know how to fix this.

If you have any advice please let me know.

Thank you!

I have experienced the same issue!
3.6.3-rc.1 Pre-release did the job for me → Release 3.6.3-rc.1 · getkirby/kirby · GitHub


1 Like

Hey Timon,

thank you for your reply! Maybe it’s a bit late now but anyway:
I updated my site to the newest version and everything is working flawlessly now!

All the best