No images generated in media folder on server

I set all permissions to 755, and checked if GD is installed. What else could it be?

Are the job files created?

These? yes

If useful, phpinfo:

PHP Version 7.3.23-4+ubuntu20.04.1+deb.sury.org+1

Have you checked your browser console and server and php error logs for something that might be enlightening?

Console says files not found, since the files are not present.
Error log is empty :frowning:

There’s a log file called access.log with things like:

openlab.tcij.org ::1 [02/Nov/2020:00:08:01 +0000] HEAD "/wp-cron.php?server_triggered_cronjob" HTTP/2.0 404 "-" "curl/7.68.0" "-" - 0 1 "/" "wp-cron" php "server_triggered_cronjob" 0 - 0 65 0.000 -
openlab.tcij.org ::1 [02/Nov/2020:00:23:01 +0000] HEAD "/wp-cron.php?server_triggered_cronjob" HTTP/2.0 404 "-" "curl/7.68.0" "-" - 0 1 "/" "wp-cron" php "server_triggered_cronjob" 0 - 0 65 0.000 -
openlab.tcij.org ::1 [02/Nov/2020:00:38:01 +0000] HEAD "/wp-cron.php?server_triggered_cronjob" HTTP/2.0 404 "-" "curl/7.68.0" "-" - 0 1 "/" "wp-cron" php "server_triggered_cronjob" 0 - 0 65 0.000 -

along with other lines about regular visits to the pages.

Hm, those lines are somehow Wordpress related, so irrelevant.

And you haven’t set another thumb driver in your config file? Is that on your local server or remote? Apache or Nginx or another webserver?

On local using MAMP everything works fine. The problem is on remote; I’m not sure what web server it is since I don’t have direct access to the hosting space – only via FTP.

Not sure this helps, in phpinfo if I search for apache all I see is this

while for nginx this

You really haven’t set IM as your thumbs driver in config?

There are some suggestions here on the forum, especially regarding nginx, but then you would have or need an nginx configuration file. And if it was an nginx server, your .htaccess wouldn’t be of any use.

I just found out that the job files are not created on the server. The ones I found there were probably uploaded via ftp from local. But still, error.log is empty. And I even tried setting the media folder to 777 and nothing changes.

I found out more
the hosting in Kinsta. It seems the issue is related to the fact that jobs are in hidden folders (.jobs, starting with a dot) and they have some security rule that prevents access or execution to/from those folders. does this ring any bell?

Is this something you experienced already? Assistance from the hosting could maybe change some settings if you are able to give some context and explain what steps the script does to generate the images. Otherwise I have no alternative but change hosting.

If this is a requirement it should probably be added to https://getkirby.com/docs/guide/quickstart#requirements

This seems to be an Apache directive. Maybe it can be changed via the .htaccess. Contact your hosting provider for assistance.

It’s not Apache but Nginx/1.19.3
I don’t think that would be possible, they didn’t mention that option.