N00b .htaccess setup

I can’t figure out how to make my website work. It does run in MAMP, but not on the web after I uploaded it on the FTP. I tried activating and deactivating both

RewriteEngine on
RewriteBase /

:frowning: SAD FACE

Is your Kirby project installed in the webroot or in a subfolder?

What is your php version?

And RewriteEngine must be on, it may or may not be necessary to set the RewriteBase, depending on your server and on whether the site is installed in a subfolder or not.

1 Like

Directly in the subfolder FTP/public_html/louischarleslasnier.com.

And the Domain points to that subfolder?

Yup; I tried putting a dumb index.html, and it does work (just putted one for you right now :smiley: )

Nice :slight_smile:

Have to ask about your PHP version again…

And what is currently in your .htaccess regarding the Rewrite stuff?

Edit: now we have error 403 forbidden right in the page… Have you changed anything?

Oh, and please check the error logs (apache error log and php error log), maybe there’s something there.

1 Like

This explains that! I just went to check on the CPanel… PHP5.2!
Sorry for the delay for this answer; I had a hard time tracking down the login for the CPanel!

Is there a preferred one between 5.4, 5.5, 5.6 or 7.0?

Thanks again for solving that n00b problem!

7.0 is your best option! Next 5.6 and so on.

1 Like