Made with Kirby and <3


#557

On Mojave as well and just switched the scroll settings to “Always” — yup, that breaks it. Is this a common problem with with Masonry? Didn’t think to test that and not sure how to fix


#558

Masonary style scripts are really hard to do. The math involved to figure it out and get good performance is just crazy. However, browsers have moved and you can get pretty much this effect now through css grid(like this https://codepen.io/balazs_sziklai/pen/mOwoLg) - theres plenty of other ways out there, google around. Im guessing that Mojave setting changes the width of the viewport in a different way, throwing out the maths and making it think there isnt room for another column.

I would file an issue on the Masonary Github, give them some time fix it (that’s actually one of the better scripts) See how long it takes to fix, and if it’s not forth coming try another masonary style script, or ditch javascript solution all together and use CSS grid (dependent on which browsers you want to support.)


#559

Got it to work! I just substituted (100vw - (100vw - 100%)) where I previously had 100vw, and it calculated the width without scroll bar. Hopefully that didn’t break anything else… Many thanks for letting me know about the issue @jimbobrjames @manuelmoreale :+1: