Invisible page wont get visible

panel

#1

i have make a new contact page but it doesn’t show on website
when i try to make it visible from ./panel/site/subpages it won’t work also and either page options not showing the visiblity controller
PLEASE HELP
thank you


#2

Do the files have the correct permissions? What happens if you do it manually by changing the folder in the filesystem. Kirby numbers the folders for visibility, so renaming the folder from “contact” to “1-contact” will make it visible (Kirby doesn’t actually need the panel at all, it’s just a nice thing to have). the number will be different depending on the other pages you have, just use the next number in sequence.

Is the site running locally or on a server somewhere? Are you using an appropriate version of php (ideally 7.x).


#3

What is the filename of the text file? What is in the corresponding blueprint for that file name?


#4

i didn’t change permissions even renaming nothing happens all new made pages are invisible site is hosted on webserver and running php 7.2


#5

i didn’t understand sorry for bad english but her’s screen from panel (./panel/site/subpages)


#6

What I meant was, what template/blueprint did you use when you created the contact page. Maybe there is something in the blueprint that forbids making the site visible. Does the visibility toggle show up at all in the sidebar when you edit the page?

05


#7

i used “contact” template for contact page and the visibility toggle not showing


#8

The contact blueprint of the starter kit contains these lines:

options: 
  delete: false
  status: false

So, status is set to false which means you can’t change the visibility of the page, until you change this setting to true.


#9

this is in the code i guess ? right


#10

In contact.yml in the /site/blueprints folder, yes.


#11

don and it’s working thank you :heart::star_struck::star_struck::star_struck::heart_eyes: